ユーザ用ツール

サイト用ツール


サイドバー

Top

検索タグ

変更履歴

メニュー


linux:commands:package_management

目次

パッケージ管理関連

パッケージ管理 [dnf/apt]

パッケージ管理

操作 Fedora Ubuntu
インストール
$ sudo dnf install package_name
$ sudo apt-get update
$ sudo apt-get install package_name
アップデート
$ sudo dnf update package_name
$ sudo apt-get install package_name
アンインストール
$ sudo dnf remove package_name
$ sudo apt-get remove package_name
インストール済
パッケージの一覧表示
$ dnf list installed
$ dnf list *package_name*
$ rpm -qa
$ rpm -qa | grep package_name
$ dpkg -l
$ dpkg -l | grep package_name


パッケージの検索
$ dnf search package_name
$ apt-cache search package_name
パッケージ内
ファイル一覧
$ dnf repoquery -l package_name
$ rpm -ql package_name
$ dpkg -L package_name
コマンドが含まれている
パッケージを調べる
$ dnf provides command_name
$ sudo apt-get install apt-file
$ sudo apt-file update
$ sudo apt-file search command_name
パッケージ依存関係の表示
$ dnf deplist package_name
-
パッケージに依存している
パッケージを表示
$ rpm -q --whatrequires package_name
-
一時的に
リポジトリを有効化
$ sudo dnf --enablerepo=remi install package_name
-
一時的に
リポジトリを無効化
$ sudo dnf --disablerepo=remi install package_name
-
グループリスト表示
$ dnf grouplist

インストール可能なグループ一覧を英語で取得する

$ bash -c 'LANG=C;dnf grouplist'


$ dnf grouplist hidden

インストール可能なグループ一覧を英語で取得する

$ bash -c 'LANG=C;dnf grouplist hidden'
-
グループ
インストール
$ sudo dnf groupinstall "X Window System"
-
GUI パッケージ管理(旧)
$ yumex
$ software-center
GUI パッケージ管理(新)
$ dnfdragora
$ software-center
キャッシュクリア
$ sudo dnf clean all

dnf / yum 比較

操作 dnf yum
ソースのダウンロード
$ dnf download --source samba
$ yumdownloader --source samba
リポジトリ同期
$ dnf reposync
$ reposync
ビルドに必要なパッケージの
インストール
$ sudo dnf builddep samba.spec
$ sudo yum-builddep samba.spec

キャッシュのキープ

Dnf の場合

$ sudo vi /etc/dnf/dnf.conf
[main]
gpgcheck=1
installonly_limit=3
clean_requirements_on_remove=true
keepcache=1 <- 追記する。

Yum の場合

$ sudo vi /etc/yum.conf
[main]
cachedir=/var/cache/yum/$basearch/$releasever
#keepcache=0
keepcache=1 <- 1 に変更する。
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=3
 
#  This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
#  It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m
 
# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d

パッケージ管理 [dnf]

パッケージ/パッケージ グループの一覧表示 [list] コマンド

インストール済パッケージの一覧 [--installed] オプション

$ dnf list --installed
インストール済みパッケージ
GeoIP.x86_64                           1.6.12-6.fc31                      @fedora
GeoIP-GeoLite-data.noarch              2018.06-4.fc31                     @fedora
ImageMagick.x86_64                     1:6.9.11.10-1.fc31.remi            @remi
ImageMagick-devel.x86_64               1:6.9.11.10-1.fc31.remi            @remi
ImageMagick-libs.x86_64                1:6.9.11.10-1.fc31.remi            @remi
LibRaw.x86_64                          0.19.5-1.fc31                      @fedora
NetworkManager.x86_64                  1:1.20.10-1.fc31                   @updates
NetworkManager-libnm.x86_64            1:1.20.10-1.fc31                   @updates
NetworkManager-team.x86_64             1:1.20.10-1.fc31                   @updates
OpenEXR-devel.x86_64                   2.3.0-4.fc31                       @fedora
OpenEXR-libs.x86_64                    2.3.0-4.fc31                       @fedora
PackageKit.x86_64                      1.1.12-14.fc31                     @updates
PackageKit-glib.x86_64                 1.1.12-14.fc31                     @updates
abattis-cantarell-fonts.noarch         0.111-3.fc31                       @fedora
acl.x86_64                             2.2.53-4.fc31                      @fedora
adobe-mappings-cmap.noarch             20171205-6.fc31                    @fedora
adobe-mappings-cmap-deprecated.noarch  20171205-6.fc31                    @fedora
adobe-mappings-pdf.noarch              20180407-4.fc31                    @fedora
adobe-source-code-pro-fonts.noarch     2.030.1.050-7.fc31                 @fedora
adwaita-cursor-theme.noarch            3.34.3-2.fc31                      @updates
adwaita-icon-theme.noarch              3.34.3-2.fc31                      @updates
alsa-lib.x86_64                        1.2.2-2.fc31                       @updates
alternatives.x86_64                    1.11-5.fc31                        @fedora
annobin.x86_64                         8.78-4.fc31                        @updates
apr.x86_64                             1.7.0-2.fc31                       @fedora
apr-devel.x86_64                       1.7.0-2.fc31                       @fedora
apr-util.x86_64                        1.6.1-11.fc31                      @fedora
apr-util-bdb.x86_64                    1.6.1-11.fc31                      @fedora
apr-util-devel.x86_64                  1.6.1-11.fc31                      @fedora
apr-util-openssl.x86_64                1.6.1-11.fc31                      @fedora
aspnetcore-runtime-3.0.x86_64          3.0.0-5.fc31                       @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
aspnetcore-targeting-pack-3.0.x86_64   3.0.0-5.fc31                       @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
at-spi2-atk.x86_64                     2.34.2-1.fc31                      @updates
at-spi2-core.x86_64                    2.34.0-1.fc31                      @fedora
atk.x86_64                             2.34.1-1.fc31                      @fedora
audit.x86_64                           3.0-0.15.20191104git1c2f876.fc31   @updates
audit-libs.x86_64                      3.0-0.15.20191104git1c2f876.fc31   @updates
authselect.x86_64                      1.1-4.fc31                         @updates
authselect-libs.x86_64                 1.1-4.fc31                         @updates
autogen-libopts.x86_64                 5.18.16-3.fc31                     @fedora
avahi-libs.x86_64                      0.7-20.fc31                        @fedora
basesystem.noarch                      11-8.fc31                          @fedora
bash.x86_64                            5.0.11-1.fc31                      @updates
bind-libs.x86_64                       32:9.11.14-2.fc31                  @updates
bind-libs-lite.x86_64                  32:9.11.14-2.fc31                  @updates
bind-license.noarch                    32:9.11.14-2.fc31                  @updates
bind-utils.x86_64                      32:9.11.14-2.fc31                  @updates
binutils.x86_64                        2.32-31.fc31                       @updates
binutils-gold.x86_64                   2.32-31.fc31                       @updates
brotli.x86_64                          1.0.7-6.fc31                       @fedora
btrfs-progs.x86_64                     5.6-1.fc31                         @updates
bzip2.x86_64                           1.0.8-1.fc31                       @fedora
bzip2-devel.x86_64                     1.0.8-1.fc31                       @fedora
bzip2-libs.x86_64                      1.0.8-1.fc31                       @fedora
c-ares.x86_64                          1.15.0-4.fc31                      @fedora
ca-certificates.noarch                 2020.2.40-1.1.fc31                 @updates
cairo.x86_64                           1.16.0-7.fc31                      @updates
cairo-gobject.x86_64                   1.16.0-7.fc31                      @updates
cdparanoia-libs.x86_64                 10.2-30.fc31                       @fedora
certbot.noarch                         1.3.0-1.fc31                       @updates
checkpolicy.x86_64                     2.9-2.fc31                         @fedora
chkconfig.x86_64                       1.11-5.fc31                        @fedora
chromedriver.x86_64                    80.0.3987.163-1.fc31               @updates
chromium-common.x86_64                 80.0.3987.163-1.fc31               @updates
chromium-libs.x86_64                   80.0.3987.163-1.fc31               @updates
chromium-libs-media.x86_64             80.0.3987.163-1.fc31               @updates
chrony.x86_64                          3.5-4.fc31                         @fedora
cmake.x86_64                           3.17.1-1.fc31                      @updates
cmake-data.noarch                      3.17.1-1.fc31                      @updates
cmake-filesystem.x86_64                3.17.1-1.fc31                      @updates
cmake-rpm-macros.noarch                3.17.1-1.fc31                      @updates
cockpit.x86_64                         217-1.fc31                         @updates
cockpit-bridge.x86_64                  217-1.fc31                         @updates
cockpit-dashboard.noarch               217-1.fc31                         @updates
cockpit-networkmanager.noarch          217-1.fc31                         @updates
cockpit-packagekit.noarch              217-1.fc31                         @updates
cockpit-pcp.x86_64                     217-1.fc31                         @updates
cockpit-system.noarch                  217-1.fc31                         @updates
cockpit-ws.x86_64                      217-1.fc31                         @updates
colord-libs.x86_64                     1.4.4-2.fc31                       @fedora
compat-openssl10.x86_64                1:1.0.2o-8.fc31                    @fedora
comps-extras.noarch                    24-6.fc31                          @fedora
coreutils.x86_64                       8.31-9.fc31                        @updates
coreutils-common.x86_64                8.31-9.fc31                        @updates
cpio.x86_64                            2.12-12.fc31                       @fedora
cpp.x86_64                             9.3.1-2.fc31                       @updates
cracklib.x86_64                        2.9.6-21.fc31                      @fedora
cracklib-dicts.x86_64                  2.9.6-21.fc31                      @fedora
createrepo_c.x86_64                    0.15.5-1.fc31                      @updates
createrepo_c-libs.x86_64               0.15.5-1.fc31                      @updates
crypto-policies.noarch                 20191128-2.gitcd267a5.fc31         @updates
cryptsetup-libs.x86_64                 2.3.0-1.fc31                       @updates
cups-libs.x86_64                       1:2.2.12-8.fc31                    @updates
curl.x86_64                            7.66.0-1.fc31                      @fedora
cyrus-sasl.x86_64                      2.1.27-3.fc31                      @updates
cyrus-sasl-devel.x86_64                2.1.27-3.fc31                      @updates
cyrus-sasl-lib.x86_64                  2.1.27-3.fc31                      @updates
dbus.x86_64                            1:1.12.16-3.fc31                   @fedora
dbus-broker.x86_64                     21-6.fc31                          @fedora
dbus-common.noarch                     1:1.12.16-3.fc31                   @fedora
dbus-daemon.x86_64                     1:1.12.16-3.fc31                   @fedora
dbus-libs.x86_64                       1:1.12.16-3.fc31                   @fedora
dbus-tools.x86_64                      1:1.12.16-3.fc31                   @fedora
dconf.x86_64                           0.34.0-1.fc31                      @fedora
deltarpm.x86_64                        3.6.2-2.fc31                       @fedora
device-mapper.x86_64                   1.02.171-1.fc31                    @updates
device-mapper-libs.x86_64              1.02.171-1.fc31                    @updates
dhcp-client.x86_64                     12:4.4.1-19.fc31                   @updates
dhcp-common.noarch                     12:4.4.1-19.fc31                   @updates
diffutils.x86_64                       3.7-3.fc31                         @fedora
distribution-gpg-keys.noarch           1.38-1.fc31                        @updates
dmidecode.x86_64                       1:3.2-3.fc31                       @fedora
dnf.noarch                             4.2.21-1.fc31                      @updates
dnf-data.noarch                        4.2.21-1.fc31                      @updates
dnf-plugins-core.noarch                4.0.15-1.fc31                      @updates
dnf-utils.noarch                       4.0.15-1.fc31                      @updates
dotnet-apphost-pack-3.0.x86_64         3.0.0-5.fc31                       @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
dotnet-host.x86_64                     3.0.0-5.fc31                       @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
dotnet-hostfxr-3.0.x86_64              3.0.0-5.fc31                       @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
dotnet-runtime-3.0.x86_64              3.0.0-5.fc31                       @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
dotnet-sdk-3.0.x86_64                  3.0.100-5.fc31                     @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
dotnet-targeting-pack-3.0.x86_64       3.0.0-5.fc31                       @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
dotnet-templates-3.0.x86_64            3.0.100-5.fc31                     @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
dracut.x86_64                          050-26.git20200316.fc31            @updates
dracut-config-rescue.x86_64            050-26.git20200316.fc31            @updates
drpm.x86_64                            0.4.1-1.fc31                       @fedora
dwz.x86_64                             0.12-11.fc31                       @fedora
e2fsprogs.x86_64                       1.45.5-1.fc31                      @updates
e2fsprogs-libs.x86_64                  1.45.5-1.fc31                      @updates
ebtables-compat.x86_64                 2.0.10-37.fc31                     @fedora
ebtables-legacy.x86_64                 2.0.10-37.fc31                     @fedora
ebtables-services.x86_64               2.0.10-37.fc31                     @fedora
efi-srpm-macros.noarch                 4-3.fc31                           @fedora
elfutils-debuginfod-client.x86_64      0.179-2.fc31                       @updates
elfutils-default-yama-scope.noarch     0.179-2.fc31                       @updates
elfutils-libelf.x86_64                 0.179-2.fc31                       @updates
elfutils-libs.x86_64                   0.179-2.fc31                       @updates
emacs-filesystem.noarch                1:26.3-1.fc31                      @updates
ethtool.x86_64                         2:5.4-1.fc31                       @updates
expat.x86_64                           2.2.8-1.fc31                       @fedora
expat-devel.x86_64                     2.2.8-1.fc31                       @fedora
expect.x86_64                          5.45.4-10.fc31                     @fedora
fedora-gpg-keys.noarch                 31-3                               @updates
fedora-logos.x86_64                    30.0.2-3.fc31                      @fedora
fedora-logos-httpd.noarch              30.0.2-3.fc31                      @fedora
fedora-obsolete-packages.noarch        31-41                              @updates
fedora-release.noarch                  31-4                               @updates
fedora-release-common.noarch           31-4                               @updates
fedora-repos.noarch                    31-3                               @updates
fftw-libs-double.x86_64                3.3.8-6.fc31                       @fedora
file.x86_64                            5.37-8.fc31                        @updates
file-libs.x86_64                       5.37-8.fc31                        @updates
filesystem.x86_64                      3.12-2.fc31                        @fedora
findutils.x86_64                       1:4.6.0-24.fc31                    @fedora
fipscheck.x86_64                       1.5.0-7.fc31                       @fedora
fipscheck-lib.x86_64                   1.5.0-7.fc31                       @fedora
firewalld.noarch                       0.7.4-1.fc31                       @updates
firewalld-filesystem.noarch            0.7.4-1.fc31                       @updates
flac-libs.x86_64                       1.3.3-1.fc31                       @fedora
fontconfig.x86_64                      2.13.92-3.fc31                     @fedora
fonts-filesystem.noarch                2.0.3-1.fc31                       @updates
fonts-srpm-macros.noarch               2.0.3-1.fc31                       @updates
fpc-srpm-macros.noarch                 1.2-2.fc31                         @fedora
freetype.x86_64                        2.10.0-3.fc31                      @fedora
freetype-devel.x86_64                  2.10.0-3.fc31                      @fedora
fribidi.x86_64                         1.0.5-5.fc31                       @updates
fstrm.x86_64                           0.5.0-1.fc31                       @updates
fuse-libs.x86_64                       2.9.9-8.fc31                       @fedora
gawk.x86_64                            5.0.1-5.fc31                       @fedora
gc.x86_64                              7.6.4-6.fc31                       @fedora
gcc.x86_64                             9.3.1-2.fc31                       @updates
gcc-c++.x86_64                         9.3.1-2.fc31                       @updates
gcr.x86_64                             3.34.0-1.fc31                      @updates
gcr-base.x86_64                        3.34.0-1.fc31                      @updates
gd.x86_64                              2.3.0-1.fc31.remi                  @remi
gdbm.x86_64                            1:1.18.1-1.fc31                    @fedora
gdbm-libs.x86_64                       1:1.18.1-1.fc31                    @fedora
gdk-pixbuf2.x86_64                     2.40.0-1.fc31                      @fedora
gdk-pixbuf2-modules.x86_64             2.40.0-1.fc31                      @fedora
geolite2-city.noarch                   20191217-1.fc31                    @updates
geolite2-country.noarch                20191217-1.fc31                    @updates
gettext.x86_64                         0.20.1-3.fc31                      @updates
gettext-libs.x86_64                    0.20.1-3.fc31                      @updates
ghc-srpm-macros.noarch                 1.5.0-1.fc31                       @fedora
git.x86_64                             2.25.4-1.fc31                      @updates
git-core.x86_64                        2.25.4-1.fc31                      @updates
git-core-doc.noarch                    2.25.4-1.fc31                      @updates
gl-manpages.noarch                     1.1-19.20190306.fc31               @fedora
glib-networking.x86_64                 2.62.3-1.fc31                      @updates
glib2.x86_64                           2.62.6-1.fc31                      @updates
glibc.x86_64                           2.30-11.fc31                       @updates
glibc-common.x86_64                    2.30-11.fc31                       @updates
glibc-devel.x86_64                     2.30-11.fc31                       @updates
glibc-headers.x86_64                   2.30-11.fc31                       @updates
glibc-langpack-ja.x86_64               2.30-11.fc31                       @updates
gmp.x86_64                             1:6.1.2-10.fc31                    @fedora
gnat-srpm-macros.noarch                4-10.fc31                          @fedora
gnome-keyring.x86_64                   3.34.0-1.fc31                      @fedora
gnupg2.x86_64                          2.2.18-2.fc31                      @updates
gnupg2-smime.x86_64                    2.2.18-2.fc31                      @updates
gnutls.x86_64                          3.6.13-1.fc31                      @updates
go-srpm-macros.noarch                  3.0.8-4.fc31                       @fedora
gobject-introspection.x86_64           1.62.0-1.fc31                      @fedora
google-droid-sans-fonts.noarch         20120715-16.fc31                   @fedora
google-noto-cjk-fonts-common.noarch    20190416-5.fc31                    @fedora
google-noto-sans-cjk-ttc-fonts.noarch  20190416-5.fc31                    @fedora
google-noto-serif-cjk-ttc-fonts.noarch 20190416-5.fc31                    @fedora
gpgme.x86_64                           1.13.1-3.fc31                      @fedora
graphite2.x86_64                       1.3.14-1.fc31                      @updates
graphviz.x86_64                        2.40.1-54.fc31                     @fedora
grep.x86_64                            3.3-3.fc31                         @fedora
groff-base.x86_64                      1.22.3-20.fc31                     @fedora
grub2-common.noarch                    1:2.02-108.fc31                    @updates
grub2-pc.x86_64                        1:2.02-108.fc31                    @updates
grub2-pc-modules.noarch                1:2.02-108.fc31                    @updates
grub2-tools.x86_64                     1:2.02-108.fc31                    @updates
grub2-tools-efi.x86_64                 1:2.02-108.fc31                    @updates
grub2-tools-extra.x86_64               1:2.02-108.fc31                    @updates
grub2-tools-minimal.x86_64             1:2.02-108.fc31                    @updates
grubby.x86_64                          8.40-36.fc31                       @fedora
gsettings-desktop-schemas.x86_64       3.34.0-1.fc31                      @fedora
gstreamer1.x86_64                      1.16.2-1.fc31                      @updates
gstreamer1-plugins-base.x86_64         1.16.2-2.fc31                      @updates
gtk-update-icon-cache.x86_64           3.24.13-2.fc31                     @updates
gtk2.x86_64                            2.24.32-6.fc31                     @updates
gtk3.x86_64                            3.24.13-2.fc31                     @updates
gts.x86_64                             0.7.6-36.20121130.fc31             @fedora
guile.x86_64                           5:2.0.14-17.fc31                   @fedora
guile22.x86_64                         2.2.6-2.fc31                       @fedora
gzip.x86_64                            1.10-1.fc31                        @fedora
harfbuzz.x86_64                        2.6.1-2.fc31                       @fedora
hdparm.x86_64                          9.58-2.fc31                        @fedora
hicolor-icon-theme.noarch              0.17-7.fc31                        @fedora
hostname.x86_64                        3.20-9.fc31                        @fedora
htop.x86_64                            2.2.0-6.fc31                       @fedora
httpd.x86_64                           2.4.43-1.fc31                      @updates
httpd-devel.x86_64                     2.4.43-1.fc31                      @updates
httpd-filesystem.noarch                2.4.43-1.fc31                      @updates
httpd-tools.x86_64                     2.4.43-1.fc31                      @updates
hwdata.noarch                          0.334-1.fc31                       @updates
ilmbase.x86_64                         2.3.0-3.fc31                       @fedora
ilmbase-devel.x86_64                   2.3.0-3.fc31                       @fedora
ima-evm-utils.x86_64                   1.2.1-2.fc31                       @fedora
info.x86_64                            6.6-2.fc31                         @fedora
initscripts.x86_64                     10.02-2.fc31                       @fedora
ipa-pgothic-fonts.noarch               003.03-15.fc31                     @fedora
ipcalc.x86_64                          0.3.0-1.fc31                       @updates
iproute.x86_64                         5.4.0-1.fc31                       @updates
iproute-tc.x86_64                      5.4.0-1.fc31                       @updates
ipset.x86_64                           7.5-1.fc31                         @updates
ipset-libs.x86_64                      7.5-1.fc31                         @updates
iptables.x86_64                        1.8.3-7.fc31                       @updates
iptables-libs.x86_64                   1.8.3-7.fc31                       @updates
iputils.x86_64                         20190515-5.fc31                    @updates
isl.x86_64                             0.16.1-9.fc31                      @fedora
iso-codes.noarch                       4.3-2.fc31                         @fedora
jansson.x86_64                         2.12-4.fc31                        @fedora
jasper-devel.x86_64                    2.0.14-9.fc31                      @fedora
jasper-libs.x86_64                     2.0.14-9.fc31                      @fedora
jbig2dec-libs.x86_64                   0.16-1.fc31                        @fedora
jbigkit-devel.x86_64                   2.1-17.fc31                        @fedora
jbigkit-libs.x86_64                    2.1-17.fc31                        @fedora
jemalloc.x86_64                        5.2.1-2.fc31                       @fedora
js-jquery.noarch                       3.5.0-2.fc31                       @updates
json-c.x86_64                          0.13.1-11.fc31                     @updates
json-glib.x86_64                       1.4.4-3.fc31                       @fedora
jsoncpp.x86_64                         1.9.1-1.fc31                       @fedora
jwhois.x86_64                          4.0-58.fc31                        @fedora
kbd.x86_64                             2.0.4-14.fc31                      @fedora
kbd-legacy.noarch                      2.0.4-14.fc31                      @fedora
kbd-misc.noarch                        2.0.4-14.fc31                      @fedora
kernel.x86_64                          5.5.17-200.fc31                    @updates
kernel.x86_64                          5.6.6-200.fc31                     @updates
kernel.x86_64                          5.6.8-200.fc31                     @updates
kernel-core.x86_64                     5.5.17-200.fc31                    @updates
kernel-core.x86_64                     5.6.6-200.fc31                     @updates
kernel-core.x86_64                     5.6.8-200.fc31                     @updates
kernel-headers.x86_64                  5.6.7-200.fc31                     @updates
kernel-modules.x86_64                  5.5.17-200.fc31                    @updates
kernel-modules.x86_64                  5.6.6-200.fc31                     @updates
kernel-modules.x86_64                  5.6.8-200.fc31                     @updates
kernel-tools.x86_64                    5.6.7-200.fc31                     @updates
kernel-tools-libs.x86_64               5.6.7-200.fc31                     @updates
keyutils-libs.x86_64                   1.6-3.fc31                         @fedora
keyutils-libs-devel.x86_64             1.6-3.fc31                         @fedora
kmod.x86_64                            26-4.fc31                          @fedora
kmod-libs.x86_64                       26-4.fc31                          @fedora
kpartx.x86_64                          0.8.0-3.fc31                       @fedora
krb5-devel.x86_64                      1.17-46.fc31                       @updates
krb5-libs.x86_64                       1.17-46.fc31                       @updates
langpacks-core-ja.noarch               2.0-7.fc31                         @fedora
langpacks-ja.noarch                    2.0-7.fc31                         @fedora
lasi.x86_64                            1.1.2-13.fc31                      @fedora
lcms2.x86_64                           2.9-6.fc31                         @fedora
lcms2-devel.x86_64                     2.9-6.fc31                         @fedora
less.x86_64                            551-2.fc31                         @fedora
lftp.x86_64                            4.9.1-1.fc31                       @updates
libICE.x86_64                          1.0.10-2.fc31                      @fedora
libICE-devel.x86_64                    1.0.10-2.fc31                      @fedora
libSM.x86_64                           1.2.3-4.fc31                       @fedora
libSM-devel.x86_64                     1.2.3-4.fc31                       @fedora
libX11.x86_64                          1.6.9-2.fc31                       @updates
libX11-common.noarch                   1.6.9-2.fc31                       @updates
libX11-devel.x86_64                    1.6.9-2.fc31                       @updates
libX11-xcb.x86_64                      1.6.9-2.fc31                       @updates
libXScrnSaver.x86_64                   1.2.3-4.fc31                       @fedora
libXau.x86_64                          1.0.9-2.fc31                       @fedora
libXau-devel.x86_64                    1.0.9-2.fc31                       @fedora
libXaw.x86_64                          1.0.13-13.fc31                     @fedora
libXcomposite.x86_64                   0.4.4-17.fc31                      @fedora
libXcursor.x86_64                      1.1.15-6.fc31                      @fedora
libXdamage.x86_64                      1.1.4-17.fc31                      @fedora
libXdamage-devel.x86_64                1.1.4-17.fc31                      @fedora
libXext.x86_64                         1.3.4-2.fc31                       @fedora
libXext-devel.x86_64                   1.3.4-2.fc31                       @fedora
libXfixes.x86_64                       5.0.3-10.fc31                      @fedora
libXfixes-devel.x86_64                 5.0.3-10.fc31                      @fedora
libXft.x86_64                          2.3.3-2.fc31                       @fedora
libXi.x86_64                           1.7.10-2.fc31                      @fedora
libXinerama.x86_64                     1.1.4-4.fc31                       @fedora
libXmu.x86_64                          1.1.3-2.fc31                       @fedora
libXpm.x86_64                          3.5.12-10.fc31                     @fedora
libXrandr.x86_64                       1.5.2-2.fc31                       @fedora
libXrender.x86_64                      0.9.10-10.fc31                     @fedora
libXt.x86_64                           1.1.5-12.20190424gitba4ec9376.fc31 @fedora
libXt-devel.x86_64                     1.1.5-12.20190424gitba4ec9376.fc31 @fedora
libXtst.x86_64                         1.2.3-10.fc31                      @fedora
libXv.x86_64                           1.0.11-10.fc31                     @fedora
libXxf86misc.x86_64                    1.0.4-5.fc31                       @fedora
libXxf86vm.x86_64                      1.1.4-12.fc31                      @fedora
libXxf86vm-devel.x86_64                1.1.4-12.fc31                      @fedora
libacl.x86_64                          2.2.53-4.fc31                      @fedora
libaio.x86_64                          0.3.111-6.fc31                     @fedora
libappstream-glib.x86_64               0.7.17-1.fc31                      @updates
libarchive.x86_64                      3.4.2-1.fc31                       @updates
libargon2.x86_64                       20171227-3.fc31                    @fedora
libassuan.x86_64                       2.5.3-2.fc31                       @fedora
libatomic_ops.x86_64                   7.6.10-2.fc31                      @fedora
libattr.x86_64                         2.4.48-7.fc31                      @fedora
libbasicobjects.x86_64                 0.1.1-43.fc31                      @fedora
libblkid.x86_64                        2.34-4.fc31                        @updates
libcap.x86_64                          2.26-6.fc31                        @fedora
libcap-ng.x86_64                       0.7.10-1.fc31                      @updates
libcollection.x86_64                   0.7.0-43.fc31                      @fedora
libcom_err.x86_64                      1.45.5-1.fc31                      @updates
libcom_err-devel.x86_64                1.45.5-1.fc31                      @updates
libcomps.x86_64                        0.1.15-1.fc31                      @updates
libcroco.x86_64                        0.6.13-2.fc31                      @fedora
libcurl.x86_64                         7.66.0-1.fc31                      @fedora
libcurl-devel.x86_64                   7.66.0-1.fc31                      @fedora
libdaemon.x86_64                       0.14-18.fc31                       @fedora
libdatrie.x86_64                       0.2.9-10.fc31                      @fedora
libdb.x86_64                           5.3.28-38.fc31                     @fedora
libdb-devel.x86_64                     5.3.28-38.fc31                     @fedora
libdb-utils.x86_64                     5.3.28-38.fc31                     @fedora
libdhash.x86_64                        0.5.0-43.fc31                      @fedora
libdnf.x86_64                          0.47.0-1.fc31                      @updates
libdrm.x86_64                          2.4.100-1.fc31                     @updates
libdrm-devel.x86_64                    2.4.100-1.fc31                     @updates
libedit.x86_64                         3.1-30.20191211cvs.fc31            @updates
libepoxy.x86_64                        1.5.3-4.fc31                       @fedora
libevent.x86_64                        2.1.8-7.fc31                       @fedora
libfdisk.x86_64                        2.34-4.fc31                        @updates
libffi.x86_64                          3.1-23.fc31                        @fedora
libffi-devel.x86_64                    3.1-23.fc31                        @fedora
libfontenc.x86_64                      1.1.3-11.fc31                      @fedora
libgcc.x86_64                          9.3.1-2.fc31                       @updates
libgcrypt.x86_64                       1.8.5-1.fc31                       @fedora
libglvnd.x86_64                        1:1.1.1-5.fc31                     @fedora
libglvnd-core-devel.x86_64             1:1.1.1-5.fc31                     @fedora
libglvnd-devel.x86_64                  1:1.1.1-5.fc31                     @fedora
libglvnd-egl.x86_64                    1:1.1.1-5.fc31                     @fedora
libglvnd-gles.x86_64                   1:1.1.1-5.fc31                     @fedora
libglvnd-glx.x86_64                    1:1.1.1-5.fc31                     @fedora
libglvnd-opengl.x86_64                 1:1.1.1-5.fc31                     @fedora
libgomp.x86_64                         9.3.1-2.fc31                       @updates
libgpg-error.x86_64                    1.36-2.fc31                        @fedora
libgs.x86_64                           9.27-4.fc31                        @updates
libgs-devel.x86_64                     9.27-4.fc31                        @updates
libgusb.x86_64                         0.3.4-1.fc31                       @updates
libicu.x86_64                          63.2-3.fc31                        @fedora
libidn.x86_64                          1.35-6.fc31                        @fedora
libidn2.x86_64                         2.3.0-1.fc31                       @updates
libijs.x86_64                          0.35-10.fc31                       @fedora
libimagequant.x86_64                   2.12.5-1.fc31                      @fedora
libini_config.x86_64                   1.3.1-43.fc31                      @fedora
libjpeg-turbo.x86_64                   2.0.2-5.fc31                       @updates
libjpeg-turbo-devel.x86_64             2.0.2-5.fc31                       @updates
libkadm5.x86_64                        1.17-46.fc31                       @updates
libkcapi.x86_64                        1.1.5-1.fc31                       @fedora
libkcapi-hmaccalc.x86_64               1.1.5-1.fc31                       @fedora
libksba.x86_64                         1.3.5-10.fc31                      @fedora
libldb.x86_64                          2.0.9-1.fc31                       @updates
liblqr-1.x86_64                        0.4.2-13.fc31                      @fedora
libmaxminddb.x86_64                    1.2.0-8.fc31                       @fedora
libmcpp.x86_64                         2.7.2-24.fc31                      @fedora
libmcrypt.x86_64                       2.5.8-26.fc31                      @fedora
libmetalink.x86_64                     0.1.3-9.fc31                       @fedora
libmnl.x86_64                          1.0.4-10.fc31                      @fedora
libmodman.x86_64                       2.0.1-20.fc31                      @fedora
libmodulemd.x86_64                     2.9.3-1.fc31                       @updates
libmodulemd1.x86_64                    1.8.16-1.fc31                      @updates
libmount.x86_64                        2.34-4.fc31                        @updates
libmpc.x86_64                          1.1.0-4.fc31                       @fedora
libndp.x86_64                          1.7-4.fc31                         @fedora
libnetfilter_conntrack.x86_64          1.0.7-3.fc31                       @fedora
libnfnetlink.x86_64                    1.0.1-16.fc31                      @fedora
libnfsidmap.x86_64                     1:2.4.3-0.fc31                     @updates
libnftnl.x86_64                        1.1.3-2.fc31                       @fedora
libnghttp2.x86_64                      1.40.0-1.fc31                      @updates
libnl3.x86_64                          3.5.0-1.fc31                       @fedora
libnl3-cli.x86_64                      3.5.0-1.fc31                       @fedora
libnsl2.x86_64                         1.2.0-5.20180605git4a062cf.fc31    @fedora
libogg.x86_64                          2:1.3.3-3.fc31                     @fedora
libpaper.x86_64                        1.1.24-25.fc31                     @fedora
libpath_utils.x86_64                   0.2.1-43.fc31                      @fedora
libpcap.x86_64                         14:1.9.1-2.fc31                    @updates
libpciaccess.x86_64                    0.15-2.fc31                        @fedora
libpipeline.x86_64                     1.5.1-3.fc31                       @fedora
libpkgconf.x86_64                      1.6.3-2.fc31                       @fedora
libpng.x86_64                          2:1.6.37-2.fc31                    @fedora
libpng-devel.x86_64                    2:1.6.37-2.fc31                    @fedora
libpq.x86_64                           12.2-1.fc31                        @updates
libpq-devel.x86_64                     12.2-1.fc31                        @updates
libproxy.x86_64                        0.4.15-14.fc31                     @fedora
libpsl.x86_64                          0.21.0-2.fc31                      @fedora
libpwquality.x86_64                    1.4.2-1.fc31                       @updates
libraqm.x86_64                         0.7.0-4.fc31                       @updates
libref_array.x86_64                    0.1.5-43.fc31                      @fedora
librepo.x86_64                         1.11.3-1.fc31                      @updates
libreport-filesystem.noarch            2.12.0-1.fc31                      @updates
librsvg2.x86_64                        2.46.4-1.fc31                      @updates
libseccomp.x86_64                      2.4.2-2.fc31                       @updates
libsecret.x86_64                       0.19.1-1.fc31                      @fedora
libselinux.x86_64                      2.9-5.fc31                         @fedora
libselinux-devel.x86_64                2.9-5.fc31                         @fedora
libselinux-utils.x86_64                2.9-5.fc31                         @fedora
libsemanage.x86_64                     2.9-3.fc31                         @fedora
libsepol.x86_64                        2.9-2.fc31                         @fedora
libsepol-devel.x86_64                  2.9-2.fc31                         @fedora
libsigsegv.x86_64                      2.11-8.fc31                        @fedora
libsmartcols.x86_64                    2.34-4.fc31                        @updates
libsolv.x86_64                         0.7.11-1.fc31                      @updates
libsoup.x86_64                         2.68.4-1.fc31                      @updates
libss.x86_64                           1.45.5-1.fc31                      @updates
libssh.x86_64                          0.9.4-2.fc31                       @updates
libssh-config.noarch                   0.9.4-2.fc31                       @updates
libsss_autofs.x86_64                   2.2.3-13.fc31                      @updates
libsss_certmap.x86_64                  2.2.3-13.fc31                      @updates
libsss_idmap.x86_64                    2.2.3-13.fc31                      @updates
libsss_nss_idmap.x86_64                2.2.3-13.fc31                      @updates
libsss_sudo.x86_64                     2.2.3-13.fc31                      @updates
libstdc++.x86_64                       9.3.1-2.fc31                       @updates
libstdc++-devel.x86_64                 9.3.1-2.fc31                       @updates
libstemmer.x86_64                      0-13.585svn.fc31                   @fedora
libtalloc.x86_64                       2.3.0-1.fc31                       @fedora
libtasn1.x86_64                        4.14-2.fc31                        @fedora
libtdb.x86_64                          1.4.2-1.fc31                       @fedora
libteam.x86_64                         1.29-2.fc31                        @fedora
libtevent.x86_64                       0.10.1-1.fc31                      @fedora
libtextstyle.x86_64                    0.20.1-3.fc31                      @updates
libthai.x86_64                         0.1.28-3.fc31                      @fedora
libtheora.x86_64                       1:1.1.1-24.fc31                    @fedora
libtiff.x86_64                         4.0.10-8.fc31                      @updates
libtiff-devel.x86_64                   4.0.10-8.fc31                      @updates
libtirpc.x86_64                        1.2.6-0.fc31                       @updates
libtool-ltdl.x86_64                    2.4.6-31.fc31                      @fedora
libunistring.x86_64                    0.9.10-6.fc31                      @fedora
libunwind.x86_64                       1.3.1-5.fc31                       @updates
libusbx.x86_64                         1.0.22-4.fc31                      @fedora
libuser.x86_64                         0.62-21.fc31                       @fedora
libutempter.x86_64                     1.1.6-17.fc31                      @fedora
libuuid.x86_64                         2.34-4.fc31                        @updates
libuv.x86_64                           1:1.37.0-1.fc31                    @updates
libverto.x86_64                        0.3.0-8.fc31                       @fedora
libverto-devel.x86_64                  0.3.0-8.fc31                       @fedora
libvisual.x86_64                       1:0.4.0-27.fc31                    @fedora
libvorbis.x86_64                       1:1.3.6-5.fc31                     @fedora
libwayland-client.x86_64               1.17.0-2.fc31                      @fedora
libwayland-cursor.x86_64               1.17.0-2.fc31                      @fedora
libwayland-egl.x86_64                  1.17.0-2.fc31                      @fedora
libwayland-server.x86_64               1.17.0-2.fc31                      @fedora
libwebp.x86_64                         1.0.3-2.fc31                       @fedora
libwebp-devel.x86_64                   1.0.3-2.fc31                       @fedora
libwmf-lite.x86_64                     0.2.12-2.fc31                      @fedora
libxcb.x86_64                          1.13.1-3.fc31                      @fedora
libxcb-devel.x86_64                    1.13.1-3.fc31                      @fedora
libxcrypt.x86_64                       4.4.16-3.fc31                      @updates
libxcrypt-compat.x86_64                4.4.16-3.fc31                      @updates
libxcrypt-devel.x86_64                 4.4.16-3.fc31                      @updates
libxkbcommon.x86_64                    0.9.1-3.fc31                       @updates
libxml2.x86_64                         2.9.10-3.fc31                      @updates
libxshmfence.x86_64                    1.3-5.fc31                         @fedora
libxslt.x86_64                         1.1.34-1.fc31                      @updates
libyaml.x86_64                         0.2.2-2.fc31                       @fedora
libyaml-devel.x86_64                   0.2.2-2.fc31                       @fedora
libzip.x86_64                          1.6.1-1.fc31.remi                  @remi
libzstd.x86_64                         1.4.4-1.fc31                       @updates
linux-atm-libs.x86_64                  2.5.1-25.fc31                      @fedora
linux-firmware.noarch                  20200421-107.fc31                  @updates
linux-firmware-whence.noarch           20200421-107.fc31                  @updates
lm_sensors-libs.x86_64                 3.5.0-6.fc31                       @fedora
lmdb-libs.x86_64                       0.9.24-1.fc31                      @updates
lttng-ust.x86_64                       2.10.4-2.fc31                      @fedora
lua-libs.x86_64                        5.3.5-6.fc31                       @fedora
lz4-libs.x86_64                        1.9.1-1.fc31                       @fedora
lzo.x86_64                             2.08-16.fc31                       @fedora
mailcap.noarch                         2.1.48-6.fc31                      @fedora
make.x86_64                            1:4.2.1-15.fc31                    @updates
man-db.x86_64                          2.8.4-5.fc31                       @fedora
mariadb.x86_64                         3:10.3.22-1.fc31                   @updates
mariadb-backup.x86_64                  3:10.3.22-1.fc31                   @updates
mariadb-common.x86_64                  3:10.3.22-1.fc31                   @updates
mariadb-connector-c.x86_64             3.1.7-1.fc31                       @updates
mariadb-connector-c-config.noarch      3.1.7-1.fc31                       @updates
mariadb-cracklib-password-check.x86_64 3:10.3.22-1.fc31                   @updates
mariadb-errmsg.x86_64                  3:10.3.22-1.fc31                   @updates
mariadb-gssapi-server.x86_64           3:10.3.22-1.fc31                   @updates
mariadb-rocksdb-engine.x86_64          3:10.3.22-1.fc31                   @updates
mariadb-server.x86_64                  3:10.3.22-1.fc31                   @updates
mariadb-server-utils.x86_64            3:10.3.22-1.fc31                   @updates
mariadb-tokudb-engine.x86_64           3:10.3.22-1.fc31                   @updates
mcpp.x86_64                            2.7.2-24.fc31                      @fedora
mercurial.x86_64                       4.9-2.fc31                         @fedora
mesa-khr-devel.x86_64                  19.2.8-1.fc31                      @updates
mesa-libEGL.x86_64                     19.2.8-1.fc31                      @updates
mesa-libGL.x86_64                      19.2.8-1.fc31                      @updates
mesa-libGL-devel.x86_64                19.2.8-1.fc31                      @updates
mesa-libGLU.x86_64                     9.0.1-1.fc31                       @fedora
mesa-libGLU-devel.x86_64               9.0.1-1.fc31                       @fedora
mesa-libgbm.x86_64                     19.2.8-1.fc31                      @updates
mesa-libglapi.x86_64                   19.2.8-1.fc31                      @updates
minizip-compat.x86_64                  1.2.11-20.fc31                     @updates
mkpasswd.x86_64                        5.5.6-1.fc31                       @updates
mock.noarch                            2.2-1.fc31                         @updates
mock-core-configs.noarch               32.6-1.fc31                        @updates
mod_http2.x86_64                       1.15.3-2.fc31                      @fedora
mod_ssl.x86_64                         1:2.4.43-1.fc31                    @updates
mongodb-org.x86_64                     4.2.6-1.amzn2                      @mongodb-org-4.2
mongodb-org-mongos.x86_64              4.2.6-1.amzn2                      @mongodb-org-4.2
mongodb-org-server.x86_64              4.2.6-1.amzn2                      @mongodb-org-4.2
mongodb-org-shell.x86_64               4.2.6-1.amzn2                      @mongodb-org-4.2
mongodb-org-tools.x86_64               4.2.6-1.amzn2                      @mongodb-org-4.2
mozjs52.x86_64                         52.9.0-5.fc31                      @fedora
mozjs60.x86_64                         60.9.0-5.fc31                      @updates
mpfr.x86_64                            3.1.6-5.fc31                       @fedora
mrtg.x86_64                            2.17.7-4.fc31                      @fedora
mysql-selinux.noarch                   1.0.0-8.fc30                       @fedora
ncurses.x86_64                         6.1-12.20190803.fc31               @fedora
ncurses-base.noarch                    6.1-12.20190803.fc31               @fedora
ncurses-c++-libs.x86_64                6.1-12.20190803.fc31               @fedora
ncurses-devel.x86_64                   6.1-12.20190803.fc31               @fedora
ncurses-libs.x86_64                    6.1-12.20190803.fc31               @fedora
net-snmp.x86_64                        1:5.8-19.fc31                      @updates
net-snmp-agent-libs.x86_64             1:5.8-19.fc31                      @updates
net-snmp-libs.x86_64                   1:5.8-19.fc31                      @updates
net-snmp-utils.x86_64                  1:5.8-19.fc31                      @updates
net-tools.x86_64                       2.0-0.55.20160912git.fc31          @fedora
netpbm.x86_64                          10.90.00-1.fc31                    @updates
netstandard-targeting-pack-2.1.x86_64  3.0.100-5.fc31                     @copr:copr.fedorainfracloud.org:group_dotnet-sig:dotnet
nettle.x86_64                          3.5.1-3.fc31                       @fedora
nftables.x86_64                        1:0.9.1-3.fc31                     @fedora
nginx-filesystem.noarch                1:1.18.0-1.fc31                    @updates
nim-srpm-macros.noarch                 3-1.fc31                           @updates
npth.x86_64                            1.6-3.fc31                         @fedora
nspr.x86_64                            4.25.0-1.fc31                      @updates
nss.x86_64                             3.51.0-1.fc31                      @updates
nss-softokn.x86_64                     3.51.0-1.fc31                      @updates
nss-softokn-freebl.x86_64              3.51.0-1.fc31                      @updates
nss-sysinit.x86_64                     3.51.0-1.fc31                      @updates
nss-util.x86_64                        3.51.0-1.fc31                      @updates
ntpdate.x86_64                         4.2.8p13-3.fc31                    @fedora
numactl-libs.x86_64                    2.0.12-3.fc31                      @fedora
ocaml-srpm-macros.noarch               5-6.fc31                           @fedora
oniguruma.x86_64                       6.9.4-1.fc31                       @updates
openblas-srpm-macros.noarch            2-6.fc31                           @fedora
openjpeg2.x86_64                       2.3.1-6.fc31                       @updates
openjpeg2-devel.x86_64                 2.3.1-6.fc31                       @updates
openjpeg2-tools.x86_64                 2.3.1-6.fc31                       @updates
openldap.x86_64                        2.4.47-3.fc31                      @fedora
openldap-devel.x86_64                  2.4.47-3.fc31                      @fedora
openssh.x86_64                         8.1p1-1.fc31                       @updates
openssh-clients.x86_64                 8.1p1-1.fc31                       @updates
openssh-server.x86_64                  8.1p1-1.fc31                       @updates
openssl.x86_64                         1:1.1.1d-2.fc31                    @fedora
openssl-devel.x86_64                   1:1.1.1d-2.fc31                    @fedora
openssl-libs.x86_64                    1:1.1.1d-2.fc31                    @fedora
openssl-pkcs11.x86_64                  0.4.10-5.fc31                      @updates
opus.x86_64                            1.3.1-2.fc31                       @fedora
orc.x86_64                             0.4.30-1.fc31                      @fedora
os-prober.x86_64                       1.77-3.fc31                        @fedora
p11-kit.x86_64                         0.23.20-1.fc31                     @updates
p11-kit-trust.x86_64                   0.23.20-1.fc31                     @updates
pam.x86_64                             1.3.1-21.fc31                      @updates
pango.x86_64                           1.44.7-1.fc31                      @updates
parted.x86_64                          3.2.153-1.fc31                     @fedora
passwd.x86_64                          0.80-7.fc31                        @updates
pciutils.x86_64                        3.6.4-1.fc31                       @updates
pciutils-libs.x86_64                   3.6.4-1.fc31                       @updates
pcp.x86_64                             5.1.0-1.fc31                       @updates
pcp-conf.x86_64                        5.1.0-1.fc31                       @updates
pcp-libs.x86_64                        5.1.0-1.fc31                       @updates
pcp-selinux.x86_64                     5.1.0-1.fc31                       @updates
pcre.x86_64                            8.44-1.fc31                        @updates
pcre2.x86_64                           10.34-9.fc31                       @updates
pcre2-devel.x86_64                     10.34-9.fc31                       @updates
pcre2-syntax.noarch                    10.34-9.fc31                       @updates
pcre2-utf16.x86_64                     10.34-9.fc31                       @updates
pcre2-utf32.x86_64                     10.34-9.fc31                       @updates
perl-CGI.noarch                        4.44-2.fc31                        @fedora
perl-Carp.noarch                       1.50-439.fc31                      @fedora
perl-Compress-Raw-Bzip2.x86_64         2.087-1.fc31                       @fedora
perl-Compress-Raw-Zlib.x86_64          2.087-1.fc31                       @fedora
perl-DBD-MySQL.x86_64                  4.050-4.fc31                       @fedora
perl-DBI.x86_64                        1.642-5.fc31                       @fedora
perl-Data-Dumper.x86_64                2.174-440.fc31                     @fedora
perl-Digest.noarch                     1.17-439.fc31                      @fedora
perl-Digest-MD5.x86_64                 2.55-439.fc31                      @fedora
perl-Encode.x86_64                     4:3.05-443.fc31                    @updates
perl-Encode-Locale.noarch              1.05-14.fc31                       @fedora
perl-Errno.x86_64                      1.30-451.fc31                      @updates
perl-Error.noarch                      1:0.17028-1.fc31                   @fedora
perl-Exporter.noarch                   5.74-1.fc31                        @updates
perl-File-Path.noarch                  2.16-439.fc31                      @fedora
perl-File-Temp.noarch                  1:0.230.900-439.fc31               @fedora
perl-Getopt-Long.noarch                1:2.51-1.fc31                      @fedora
perl-Git.noarch                        2.25.4-1.fc31                      @updates
perl-HTML-Parser.x86_64                3.72-19.fc31                       @fedora
perl-HTML-Tagset.noarch                3.20-40.fc31                       @fedora
perl-HTTP-Date.noarch                  6.05-1.fc31                        @updates
perl-HTTP-Message.noarch               6.22-1.fc31                        @updates
perl-HTTP-Tiny.noarch                  0.076-439.fc31                     @fedora
perl-IO.x86_64                         1.40-451.fc31                      @updates
perl-IO-Compress.noarch                2.087-1.fc31                       @fedora
perl-IO-HTML.noarch                    1.001-15.fc31                      @fedora
perl-IO-Socket-INET6.noarch            2.72-17.fc31                       @fedora
perl-IO-Socket-IP.noarch               0.39-440.fc31                      @fedora
perl-IO-Socket-SSL.noarch              2.066-7.fc31                       @updates
perl-LWP-MediaTypes.noarch             6.04-3.fc31                        @fedora
perl-MIME-Base64.x86_64                3.15-439.fc31                      @fedora
perl-Math-BigInt.noarch                1:1.9998.16-439.fc31               @fedora
perl-Math-Complex.noarch               1.59-451.fc31                      @updates
perl-Mozilla-CA.noarch                 20180117-6.fc31                    @fedora
perl-Net-SSLeay.x86_64                 1.88-3.fc31                        @fedora
perl-PathTools.x86_64                  3.78-439.fc31                      @fedora
perl-Pod-Escapes.noarch                1:1.07-439.fc31                    @fedora
perl-Pod-Perldoc.noarch                3.28.01-442.fc31                   @fedora
perl-Pod-Simple.noarch                 1:3.39-2.fc31                      @fedora
perl-Pod-Usage.noarch                  4:1.70-1.fc31                      @updates
perl-SNMP_Session.noarch               1.13-22.fc31                       @fedora
perl-Scalar-List-Utils.x86_64          3:1.53-439.fc31                    @updates
perl-Socket.x86_64                     4:2.029-4.fc31                     @fedora
perl-Socket6.x86_64                    0.29-4.fc31                        @fedora
perl-Storable.x86_64                   1:3.15-442.fc31                    @updates
perl-Term-ANSIColor.noarch             4.06-440.fc31                      @fedora
perl-Term-Cap.noarch                   1.17-439.fc31                      @fedora
perl-TermReadKey.x86_64                2.38-4.fc31                        @fedora
perl-Text-ParseWords.noarch            3.30-439.fc31                      @fedora
perl-Text-Tabs+Wrap.noarch             2013.0523-439.fc31                 @fedora
perl-Time-Local.noarch                 2:1.300-1.fc31                     @updates
perl-TimeDate.noarch                   1:2.30-19.fc31                     @updates
perl-URI.noarch                        1.76-5.fc31                        @fedora
perl-Unicode-Normalize.x86_64          1.26-439.fc31                      @fedora
perl-constant.noarch                   1.33-440.fc31                      @fedora
perl-interpreter.x86_64                4:5.30.2-451.fc31                  @updates
perl-libnet.noarch                     3.11-440.fc31                      @fedora
perl-libs.x86_64                       4:5.30.2-451.fc31                  @updates
perl-macros.noarch                     4:5.30.2-451.fc31                  @updates
perl-parent.noarch                     1:0.237-439.fc31                   @fedora
perl-podlators.noarch                  1:4.12-2.fc31                      @fedora
perl-srpm-macros.noarch                1-33.fc31                          @fedora
perl-threads.x86_64                    1:2.22-439.fc31                    @fedora
perl-threads-shared.x86_64             1.60-440.fc31                      @fedora
php.x86_64                             7.3.17-1.fc31.remi                 @remi-modular
php-cli.x86_64                         7.3.17-1.fc31.remi                 @remi-modular
php-common.x86_64                      7.3.17-1.fc31.remi                 @remi-modular
php-fedora-autoloader.noarch           1.0.1-2.fc31.remi                  @remi
php-fpm.x86_64                         7.3.17-1.fc31.remi                 @remi-modular
php-gd.x86_64                          7.3.17-1.fc31.remi                 @remi-modular
php-json.x86_64                        7.3.17-1.fc31.remi                 @remi-modular
php-mbstring.x86_64                    7.3.17-1.fc31.remi                 @remi-modular
php-mysqlnd.x86_64                     7.3.17-1.fc31.remi                 @remi-modular
php-opcache.x86_64                     7.3.17-1.fc31.remi                 @remi-modular
php-pdo.x86_64                         7.3.17-1.fc31.remi                 @remi-modular
php-pear.noarch                        1:1.10.12-1.fc31.remi              @remi
php-pecl-apcu.x86_64                   5.1.18-1.fc31.remi.7.3             @remi-modular
php-pecl-apcu-bc.x86_64                1.0.5-2.fc31                       @fedora
php-pecl-mcrypt.x86_64                 1.0.3-1.fc31.remi.7.3              @remi-modular
php-pecl-zip.x86_64                    1.18.2-1.fc31.remi.7.3             @remi-modular
php-process.x86_64                     7.3.17-1.fc31.remi                 @remi-modular
php-xml.x86_64                         7.3.17-1.fc31.remi                 @remi-modular
pigz.x86_64                            2.4-5.fc31                         @fedora
pinentry.x86_64                        1.1.0-6.fc31                       @fedora
pipewire.x86_64                        0.2.7-2.fc31                       @updates
pipewire-libs.x86_64                   0.2.7-2.fc31                       @updates
pixman.x86_64                          0.38.4-1.fc31                      @fedora
pkgconf.x86_64                         1.6.3-2.fc31                       @fedora
pkgconf-m4.noarch                      1.6.3-2.fc31                       @fedora
pkgconf-pkg-config.x86_64              1.6.3-2.fc31                       @fedora
plymouth.x86_64                        0.9.4-14.20200325gite31c81f.fc31   @updates
plymouth-core-libs.x86_64              0.9.4-14.20200325gite31c81f.fc31   @updates
plymouth-scripts.x86_64                0.9.4-14.20200325gite31c81f.fc31   @updates
policycoreutils.x86_64                 2.9-5.fc31                         @fedora
policycoreutils-python-utils.noarch    2.9-5.fc31                         @fedora
polkit.x86_64                          0.116-4.fc31.1                     @updates
polkit-libs.x86_64                     0.116-4.fc31.1                     @updates
polkit-pkla-compat.x86_64              0.1-15.fc31                        @fedora
popt.x86_64                            1.16-18.fc31                       @fedora
postgresql.x86_64                      11.7-1.fc31                        @updates
postgresql-contrib.x86_64              11.7-1.fc31                        @updates
postgresql-server.x86_64               11.7-1.fc31                        @updates
postgresql-upgrade.x86_64              11.7-1.fc31                        @updates
powershell-preview.x86_64              7.0.0_rc.2-1.centos.8              @@commandline
ppp.x86_64                             2.4.7-35.fc31                      @updates
procmail.x86_64                        3.22-51.fc31                       @fedora
procps-ng.x86_64                       3.3.15-6.fc31                      @fedora
protobuf-c.x86_64                      1.3.1-3.fc31                       @fedora
psmisc.x86_64                          23.3-2.fc31                        @updates
publicsuffix-list-dafsa.noarch         20190417-2.fc31                    @fedora
python-josepy-doc.noarch               1.2.0-2.fc31                       @fedora
python-pip-wheel.noarch                19.1.1-7.fc31                      @updates
python-rpm-macros.noarch               3-55.fc31                          @updates
python-setuptools-wheel.noarch         41.6.0-1.fc31                      @updates
python-srpm-macros.noarch              3-55.fc31                          @updates
python-systemd-doc.x86_64              234-9.fc31                         @fedora
python-unversioned-command.noarch      3.7.7-1.fc31                       @updates
python-wheel-wheel.noarch              1:0.33.1-3.fc31                    @fedora
python2.x86_64                         2.7.17-1.fc31                      @updates
python2-devel.x86_64                   2.7.17-1.fc31                      @updates
python2-libs.x86_64                    2.7.17-1.fc31                      @updates
python2-pip.noarch                     19.1.1-7.fc31                      @updates
python2-rpm-macros.noarch              3-55.fc31                          @updates
python2-setuptools.noarch              41.6.0-1.fc31                      @updates
python2-tkinter.x86_64                 2.7.17-1.fc31                      @updates
python2-tools.x86_64                   2.7.17-1.fc31                      @updates
python3.x86_64                         3.7.7-1.fc31                       @updates
python3-acme.noarch                    1.3.0-1.fc31                       @updates
python3-asn1crypto.noarch              0.24.0-7.fc31                      @fedora
python3-audit.x86_64                   3.0-0.15.20191104git1c2f876.fc31   @updates
python3-babel.noarch                   2.7.0-2.fc31                       @fedora
python3-bind.noarch                    32:9.11.14-2.fc31                  @updates
python3-certbot.noarch                 1.3.0-1.fc31                       @updates
python3-cffi.x86_64                    1.12.3-1.fc31                      @fedora
python3-chardet.noarch                 3.0.4-10.fc31                      @fedora
python3-configargparse.noarch          0.15.2-1.fc31                      @updates
python3-configobj.noarch               5.0.6-16.fc31                      @fedora
python3-cryptography.x86_64            2.6.1-3.fc31                       @updates
python3-dateutil.noarch                1:2.8.0-3.fc31                     @fedora
python3-dbus.x86_64                    1.2.8-6.fc31                       @fedora
python3-decorator.noarch               4.4.0-2.fc31                       @fedora
python3-devel.x86_64                   3.7.7-1.fc31                       @updates
python3-distro.noarch                  1.4.0-2.fc31                       @fedora
python3-dmidecode.x86_64               3.12.2-16.fc31                     @fedora
python3-dnf.noarch                     4.2.21-1.fc31                      @updates
python3-dnf-plugin-system-upgrade.noarch
                                       4.0.10-1.fc31                      @updates
python3-dnf-plugins-core.noarch        4.0.15-1.fc31                      @updates
python3-dnf-plugins-extras-common.noarch
                                       4.0.10-1.fc31                      @updates
python3-firewall.noarch                0.7.4-1.fc31                       @updates
python3-funcsigs.noarch                1.0.2-13.fc31                      @fedora
python3-future.noarch                  0.18.2-2.fc31                      @updates
python3-gobject-base.x86_64            3.34.0-3.fc31                      @fedora
python3-gpg.x86_64                     1.13.1-3.fc31                      @fedora
python3-hawkey.x86_64                  0.47.0-1.fc31                      @updates
python3-idna.noarch                    2.8-2.fc31                         @fedora
python3-iniparse.noarch                0.4-34.fc31                        @fedora
python3-jinja2.noarch                  2.10.1-2.fc31                      @fedora
python3-josepy.noarch                  1.2.0-2.fc31                       @fedora
python3-libcomps.x86_64                0.1.15-1.fc31                      @updates
python3-libdnf.x86_64                  0.47.0-1.fc31                      @updates
python3-libs.x86_64                    3.7.7-1.fc31                       @updates
python3-libselinux.x86_64              2.9-5.fc31                         @fedora
python3-libsemanage.x86_64             2.9-3.fc31                         @fedora
python3-libxml2.x86_64                 2.9.10-3.fc31                      @updates
python3-linux-procfs.noarch            0.6.1-3.fc31                       @fedora
python3-markupsafe.x86_64              1.1.1-2.fc31                       @fedora
python3-mock.noarch                    3.0.5-2.fc31                       @fedora
python3-ndg_httpsclient.noarch         0.5.1-2.fc31                       @fedora
python3-parsedatetime.noarch           2.4-13.fc31                        @fedora
python3-pbr.noarch                     5.1.2-4.fc31                       @fedora
python3-perf.x86_64                    5.6.7-200.fc31                     @updates
python3-pip.noarch                     19.1.1-7.fc31                      @updates
python3-ply.noarch                     3.11-3.fc31                        @fedora
python3-policycoreutils.noarch         2.9-5.fc31                         @fedora
python3-pyOpenSSL.noarch               19.0.0-2.fc31                      @fedora
python3-pyasn1.noarch                  0.4.4-5.fc31                       @fedora
python3-pycparser.noarch               2.14-20.fc31                       @fedora
python3-pyrfc3339.noarch               1.0-14.fc31                        @fedora
python3-pyroute2.noarch                0.5.3-6.fc31                       @fedora
python3-pysocks.noarch                 1.7.0-2.fc31                       @fedora
python3-pytz.noarch                    2019.2-1.fc31                      @fedora
python3-pyudev.noarch                  0.21.0-11.fc31                     @fedora
python3-requests.noarch                2.22.0-3.fc31                      @fedora
python3-requests-toolbelt.noarch       0.9.1-3.fc31                       @fedora
python3-rpm.x86_64                     4.15.1-1.fc31                      @updates
python3-rpm-generators.noarch          9-2.fc31                           @fedora
python3-rpm-macros.noarch              3-55.fc31                          @updates
python3-schedutils.x86_64              0.6-8.fc31                         @fedora
python3-setools.x86_64                 4.2.2-2.fc31                       @updates
python3-setuptools.noarch              41.6.0-1.fc31                      @updates
python3-six.noarch                     1.12.0-2.fc31                      @fedora
python3-slip.noarch                    0.6.4-16.fc31                      @fedora
python3-slip-dbus.noarch               0.6.4-16.fc31                      @fedora
python3-systemd.x86_64                 234-9.fc31                         @fedora
python3-unbound.x86_64                 1.9.6-1.fc31                       @updates
python3-urllib3.noarch                 1.25.7-1.fc31                      @updates
python3-virtualenv.noarch              16.6.2-1.fc31                      @updates
python3-zope-component.noarch          4.3.0-9.fc31                       @fedora
python3-zope-event.noarch              4.2.0-13.fc31                      @fedora
python3-zope-interface.x86_64          4.6.0-2.fc31                       @fedora
qrencode-libs.x86_64                   4.0.2-4.fc31                       @fedora
qt5-srpm-macros.noarch                 5.13.2-1.fc31                      @updates
readline.x86_64                        8.0-3.fc31                         @fedora
readline-devel.x86_64                  8.0-3.fc31                         @fedora
redhat-rpm-config.noarch               143-1.fc31                         @updates
remi-release.noarch                    31-2.fc31.remi                     @remi
rest.x86_64                            0.8.1-6.fc31                       @fedora
rhash.x86_64                           1.3.8-2.fc31                       @fedora
rootfiles.noarch                       8.1-25.fc31                        @fedora
rp-pppoe.x86_64                        3.12-14.fc31                       @fedora
rpm.x86_64                             4.15.1-1.fc31                      @updates
rpm-build-libs.x86_64                  4.15.1-1.fc31                      @updates
rpm-libs.x86_64                        4.15.1-1.fc31                      @updates
rpm-plugin-selinux.x86_64              4.15.1-1.fc31                      @updates
rpm-plugin-systemd-inhibit.x86_64      4.15.1-1.fc31                      @updates
rpm-sign-libs.x86_64                   4.15.1-1.fc31                      @updates
rpmfusion-free-release.noarch          31-1                               @rpmfusion-free
rpmfusion-nonfree-release.noarch       31-2                               @rpmfusion-nonfree-updates
rsync.x86_64                           3.1.3-10.fc31                      @updates
rtkit.x86_64                           0.11-22.fc31                       @fedora
ruby.x86_64                            2.6.5-124.fc31                     @updates
ruby-devel.x86_64                      2.6.5-124.fc31                     @updates
ruby-libs.x86_64                       2.6.5-124.fc31                     @updates
rubygem-bigdecimal.x86_64              1.4.1-124.fc31                     @updates
rubygem-did_you_mean.noarch            1.3.0-124.fc31                     @updates
rubygem-io-console.x86_64              0.4.7-124.fc31                     @updates
rubygem-irb.noarch                     1.0.0-124.fc31                     @updates
rubygem-json.x86_64                    2.2.0-202.fc31                     @updates
rubygem-openssl.x86_64                 2.1.2-124.fc31                     @updates
rubygem-psych.x86_64                   3.1.0-124.fc31                     @updates
rubygem-rdoc.noarch                    6.1.2-124.fc31                     @updates
rubygems.noarch                        3.0.3-124.fc31                     @updates
rubypick.noarch                        1.1.1-11.fc31                      @fedora
rust-srpm-macros.noarch                14-1.fc31                          @updates
sbc.x86_64                             1.4-3.fc31                         @fedora
screen.x86_64                          4.6.2-9.fc31                       @fedora
sed.x86_64                             4.5-4.fc31                         @fedora
selinux-policy.noarch                  3.14.4-50.fc31                     @updates
selinux-policy-targeted.noarch         3.14.4-50.fc31                     @updates
sendmail.x86_64                        8.15.2-40.fc31                     @updates
setup.noarch                           2.13.6-1.fc31                      @updates
shadow-utils.x86_64                    2:4.6-18.fc31                      @updates
shared-mime-info.x86_64                1.15-1.fc31                        @updates
sqlite-libs.x86_64                     3.30.0-1.fc31                      @updates
sscg.x86_64                            2.6.1-1.fc31                       @updates
sssd-client.x86_64                     2.2.3-13.fc31                      @updates
sssd-common.x86_64                     2.2.3-13.fc31                      @updates
sssd-kcm.x86_64                        2.2.3-13.fc31                      @updates
sssd-nfs-idmap.x86_64                  2.2.3-13.fc31                      @updates
strace.x86_64                          5.6-1.fc31                         @updates
sudo.x86_64                            1.9.0-0.1.b4.fc31                  @updates
systemd.x86_64                         243.8-1.fc31                       @updates
systemd-bootchart.x86_64               233-5.fc31                         @fedora
systemd-container.x86_64               243.8-1.fc31                       @updates
systemd-libs.x86_64                    243.8-1.fc31                       @updates
systemd-pam.x86_64                     243.8-1.fc31                       @updates
systemd-rpm-macros.noarch              243.8-1.fc31                       @updates
systemd-udev.x86_64                    243.8-1.fc31                       @updates
tar.x86_64                             2:1.32-2.fc31                      @fedora
tcl.x86_64                             1:8.6.8-2.fc31                     @fedora
teamd.x86_64                           1.29-2.fc31                        @fedora
tix.x86_64                             1:8.4.3-27.fc31                    @fedora
tk.x86_64                              1:8.6.8-2.fc31                     @updates
tmux.x86_64                            2.9a-3.fc31                        @fedora
tomoyan-release-29.noarch              1.0-0                              @@commandline
trousers.x86_64                        0.3.13-13.fc31                     @fedora
trousers-lib.x86_64                    0.3.13-13.fc31                     @fedora
tss2.x86_64                            1331-2.fc31                        @fedora
tuned.noarch                           2.13.0-1.fc31                      @updates
tzdata.noarch                          2019c-2.fc31                       @updates
unbound-libs.x86_64                    1.9.6-1.fc31                       @updates
unzip.x86_64                           6.0-44.fc31                        @fedora
urw-base35-bookman-fonts.noarch        20170801-13.fc31                   @fedora
urw-base35-c059-fonts.noarch           20170801-13.fc31                   @fedora
urw-base35-d050000l-fonts.noarch       20170801-13.fc31                   @fedora
urw-base35-fonts.noarch                20170801-13.fc31                   @fedora
urw-base35-fonts-common.noarch         20170801-13.fc31                   @fedora
urw-base35-gothic-fonts.noarch         20170801-13.fc31                   @fedora
urw-base35-nimbus-mono-ps-fonts.noarch 20170801-13.fc31                   @fedora
urw-base35-nimbus-roman-fonts.noarch   20170801-13.fc31                   @fedora
urw-base35-nimbus-sans-fonts.noarch    20170801-13.fc31                   @fedora
urw-base35-p052-fonts.noarch           20170801-13.fc31                   @fedora
urw-base35-standard-symbols-ps-fonts.noarch
                                       20170801-13.fc31                   @fedora
urw-base35-z003-fonts.noarch           20170801-13.fc31                   @fedora
usbutils.x86_64                        012-3.fc31                         @fedora
usermode.x86_64                        1.112-5.fc31                       @fedora
userspace-rcu.x86_64                   0.11.1-2.fc31                      @fedora
util-linux.x86_64                      2.34-4.fc31                        @updates
uuid.x86_64                            1.6.2-45.fc31                      @fedora
vim-minimal.x86_64                     2:8.2.587-1.fc31                   @updates
virt-what.x86_64                       1.19-3.fc31                        @fedora
web-assets-filesystem.noarch           5-10.fc31                          @fedora
which.x86_64                           2.21-15.fc31                       @fedora
whois-nls.noarch                       5.5.6-1.fc31                       @updates
xkeyboard-config.noarch                2.28-1.fc31                        @updates
xml-common.noarch                      0.6.3-53.fc31                      @fedora
xorg-x11-font-utils.x86_64             1:7.5-43.fc31                      @updates
xorg-x11-fonts-ISO8859-1-100dpi.noarch 7.5-23.fc31                        @fedora
xorg-x11-proto-devel.noarch            2019.1-2.fc31                      @fedora
xorg-x11-server-utils.x86_64           7.7-32.fc31                        @fedora
xz.x86_64                              5.2.4-6.fc31                       @fedora
xz-libs.x86_64                         5.2.4-6.fc31                       @fedora
yum.noarch                             4.2.21-1.fc31                      @updates
zchunk-libs.x86_64                     1.1.5-1.fc31                       @updates
zip.x86_64                             3.0-25.fc31                        @fedora
zlib.x86_64                            1.2.11-20.fc31                     @updates
zlib-devel.x86_64                      1.2.11-20.fc31                     @updates

コマンドのヘルプを表示 [--help] オプション

$ dnf list --help
usage: dnf list [-c [config file]] [-q] [-v] [--version]
                [--installroot [path]] [--nodocs] [--noplugins]
                [--enableplugin [plugin]] [--disableplugin [plugin]]
                [--releasever RELEASEVER] [--setopt SETOPTS] [--skip-broken]
                [-h] [--allowerasing] [-b | --nobest] [-C] [-R [minutes]]
                [-d [debug level]] [--debugsolver] [--showduplicates]
                [-e ERRORLEVEL] [--obsoletes]
                [--rpmverbosity [debug level name]] [-y] [--assumeno]
                [--enablerepo [repo]] [--disablerepo [repo] | --repo [repo]]
                [--enable | --disable] [-x [package]]
                [--disableexcludes [repo]] [--repofrompath [repo,path]]
                [--noautoremove] [--nogpgcheck] [--color COLOR] [--refresh]
                [-4] [-6] [--destdir DESTDIR] [--downloadonly]
                [--comment COMMENT] [--bugfix] [--enhancement] [--newpackage]
                [--security] [--advisory ADVISORY] [--bz BUGZILLA]
                [--cve CVES]
                [--sec-severity {Critical,Important,Moderate,Low}]
                [--forcearch ARCH]
                [--all | --available | --installed | --extras | --updates | --upgrades | --autoremove | --recent]
                [パッケージ [パッケージ ...]]

パッケージまたはパッケージのグループを一覧表示します

General DNF options:
  -c [config file], --config [config file]
                        設定ファイルの場所
  -q, --quiet           静かな操作
  -v, --verbose         詳細な操作
  --version             show DNF version and exit
  --installroot [path]  インストール root を設定します
  --nodocs              ドキュメントをインストールしません
  --noplugins           すべてのプラグインを無効にします
  --enableplugin [plugin]
                        名前ごとにプラグインを有効にします
  --disableplugin [plugin]
                        名前ごとにプラグインを無効にします
  --releasever RELEASEVER
                        設定ファイルと repo ファイルの $releasever の値をオーバーライドします
  --setopt SETOPTS      任意の設定オプションと repo オプションを設定します
  --skip-broken         パッケージをスキップして depsolve 問題を解決します
  -h, --help, --help-cmd
                        コマンドのヘルプを表示する
  --allowerasing        依存関係を解決するために、インストール済みパッケージの消去を許可します
  -b, --best            トランザクションにおいて利用可能な最適なパッケージバージョンを試してください。
  --nobest              do not limit the transaction to the best candidate
  -C, --cacheonly       システムキャッシュから全面的に実行し、キャッシュは更新しません
  -R [minutes], --randomwait [minutes]
                        コマンドの最大待ち時間
  -d [debug level], --debuglevel [debug level]
                        出力レベルをデバッグします
  --debugsolver         ファイルに詳細な解決結果をダンプします
  --showduplicates      一覧/検索コマンドで repo の重複を表示します
  -e ERRORLEVEL, --errorlevel ERRORLEVEL
                        エラー出力レベル
  --obsoletes           enables dnf's obsoletes processing logic for upgrade
                        or display capabilities that the package obsoletes for
                        info, list and repoquery
  --rpmverbosity [debug level name]
                        rpm の出力レベルをデバッグします
  -y, --assumeyes       すべての質問に「はい」(yes) と自動的に答えます
  --assumeno            すべての質問に「いいえ」(no) と自動的に答えます
  --enablerepo [repo]   Enable additional repositories. List option. Supports
                        globs, can be specified multiple times.
  --disablerepo [repo]  Disable repositories. List option. Supports globs, can
                        be specified multiple times.
  --repo [repo], --repoid [repo]
                        id または glob により特定のリポジトリーだけを有効にします。複数回指定することが可能です
  --enable, --set-enabled
                        enable repos with config-manager command
                        (automatically saves)
  --disable, --set-disabled
                        disable repos with config-manager command
                        (automatically saves)
  -x [package], --exclude [package], --excludepkgs [package]
                        名前または glob ごとにパッケージを除外します
  --disableexcludes [repo], --disableexcludepkgs [repo]
                        excludepkgs を無効にします
  --repofrompath [repo,path]
                        label and path to an additional repository to use
                        (same path as in a baseurl), can be specified multiple
                        times.
  --noautoremove        もはや使用されていない依存関係の削除を無効にします
  --nogpgcheck          disable gpg signature checking (if RPM policy allows)
  --color COLOR         色を使うかどうか制御します
  --refresh             コマンド実行前にメタデータを期限切れに設定します
  -4                    IPv4 アドレスのみを解決します
  -6                    IPv6 アドレスのみを解決します
  --destdir DESTDIR, --downloaddir DESTDIR
                        パッケージをコピーするディレクトリーを設定します
  --downloadonly        パッケージのみをダウンロードします
  --comment COMMENT     トランザクションにコメントを追加します
  --bugfix              バグ修正関連パッケージを更新に含めます
  --enhancement         機能拡張関連パッケージを更新に含めます
  --newpackage          newpackage の関連パッケージを更新に含めます
  --security            セキュリティー関連パッケージを更新に含めます
  --advisory ADVISORY, --advisories ADVISORY
                        特定のアドバイザリーの修正に必要なパッケージを更新に含めます
  --bz BUGZILLA, --bzs BUGZILLA
                        特定の BZ の修正に必要なパッケージを更新に含めます
  --cve CVES, --cves CVES
                        特定の CVE の修正に必要なパッケージを更新に含めます
  --sec-severity {Critical,Important,Moderate,Low}, --secseverity {Critical,Important,Moderate,Low}
                        深刻度に一致するセキュリティー関連パッケージを更新に含めます
  --forcearch ARCH      アーキテクチャーの使用を強制します

List command-specific options:
  --all                 すべてのパッケージを表示します (デフォルト)
  --available           利用可能なパッケージのみを表示します
  --installed           インストール済みのパッケージのみを表示します
  --extras              エクストラパッケージのみを表示します
  --updates             アップグレードパッケージのみを表示します
  --upgrades            アップグレードパッケージのみを表示します
  --autoremove          自動削除パッケージのみを表示します
  --recent              最近変更されたパッケージのみを表示します

  パッケージ                 Package name specification

パッケージのインストール容量の削減 (ドキュメント類をインストール対象から除外 [nodocs])

Docker や WSL 2 (軽量ユーティリティ VM) などのコンテナ仮想化技術を利用する場合、コンテナの肥大化を防止するためにパッケージをインストールする際にパッケージマネージャがドキュメント類を除外するように指示することができる。
また、Raspberry Pi (ラズベリー パイ) の SD カードのように消費容量を削減したいプラットフォームでも、この機能を利用する価値があるかもしれません🤤

この機能を利用すると、ドキュメント類がインストールされないので、man コマンドなどで説明が見られない状態になりますが、必要に応じてパッケージ毎の個別に、ドキュメント類をインストールする方法も記載しておきます😊

パッケージマネージャの設定変更

dnf コマンドの設定で tsflags で RPM トランザクション フラグに nodocs (RPMTRANS_FLAG_NODOCS) を設定する事で、パッケージのインストール時にドキュメント類を除外することができる。

$ sudo vi /etc/dnf/dnf.conf
/etc/dnf/dnf.conf
[main]
gpgcheck=1
installonly_limit=3
clean_requirements_on_remove=True
best=False
skip_if_unavailable=True
tsflags=nodocs # <- これを追記

パッケージインストール時に個別にドキュメント類もインストールするように指示する

基本は dnf.conftsflags=nodocs のままで、パッケージ毎に必要に応じてドキュメント類のインストールを指示するには、--setopt オプションに空の tsflags を指定して nodocs RPM トランザクション フラグの指定を一時的に解除する。

$ sudo dnf install --setopt=tsflags='' man-db man-pages man-pages-ja -y

既にインストール済みのパッケージで、後からドキュメント類が必要になった場合は、以下の方法で再インストールする必要があります。(既に tsflags=nodocs でインストールしたパッケージはドキュメント類自体が欠落して配置されているためです)

$ sudo dnf reinstall --setopt=tsflags='' man-db man-pages man-pages-ja -y

パッケージインストール時に個別にドキュメント類をインストールしないように指示する

基本は dnf.conf で RPM トランザクション フラグを指定しないで、パッケージ毎に必要に応じてドキュメント類をインストールしないように指示するには、--setopt オプションに tsflags を指定して nodocs (RPMTRANS_FLAG_NODOCS) RPM トランザクション フラグを指定する。

$ sudo dnf reinstall --setopt=tsflags=nodocs rsync -y
Last metadata expiration check: 2:36:59 ago on 2021年03月25日 10時06分56秒.
Dependencies resolved.
====================================================================================================
 Package             Architecture         Version                       Repository             Size
====================================================================================================
Reinstalling:
 rsync               x86_64               3.2.3-3.fc33                  updates               393 k

Transaction Summary
====================================================================================================

Total download size: 393 k
Installed size: 731 k
Downloading Packages:
rsync-3.2.3-3.fc33.x86_64.rpm                                       550 kB/s | 393 kB     00:00
----------------------------------------------------------------------------------------------------
Total                                                               153 kB/s | 393 kB     00:02
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                            1/1
  Reinstalling     : rsync-3.2.3-3.fc33.x86_64                                                  1/2
  Cleanup          : rsync-3.2.3-3.fc33.x86_64                                                  2/2
  Running scriptlet: rsync-3.2.3-3.fc33.x86_64                                                  2/2
  Verifying        : rsync-3.2.3-3.fc33.x86_64                                                  1/2
  Verifying        : rsync-3.2.3-3.fc33.x86_64                                                  2/2

Reinstalled:
  rsync-3.2.3-3.fc33.x86_64

Complete!

ドキュメント類がインストールされていないことを確認するには以下のコマンドを実行する。

$ ls -lha $(rpm -q -d rsync)
ls: cannot access '/usr/share/doc/rsync/support/Makefile': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/atomic-rsync': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/cvs2includes': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/deny-rsync': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/file-attr-restore': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/files-to-excludes': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/git-set-file-times': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/instant-rsyncd': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/logfilter': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/lsh': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/lsh.sh': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/mapfrom': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/mapto': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/mnt-excl': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/munge-symlinks': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/nameconvert': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/rrsync': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/rsync-no-vanished': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/rsync-slash-strip': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/rsyncstats': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/savetransfer.c': No such file or directory
ls: cannot access '/usr/share/doc/rsync/tech_report.tex': No such file or directory
ls: cannot access '/usr/share/man/man1/rsync-ssl.1.gz': No such file or directory
ls: cannot access '/usr/share/man/man1/rsync.1.gz': No such file or directory
ls: cannot access '/usr/share/man/man5/rsyncd.conf.5.gz': No such file or directory

tsflags=nodocs の RPM トランザクション フラグでインストール済みのパッケージのドキュメント類を再インストールする

既にインストール済みのパッケージで欠落しているドキュメント類のファイルは以下のように調べることが出来る🤤

$ man rsync
No manual entry for rsync
$ ls -lha $(rpm -q -d rsync)
ls: cannot access '/usr/share/doc/rsync/support/Makefile': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/atomic-rsync': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/cvs2includes': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/deny-rsync': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/file-attr-restore': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/files-to-excludes': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/git-set-file-times': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/instant-rsyncd': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/logfilter': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/lsh': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/lsh.sh': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/mapfrom': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/mapto': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/mnt-excl': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/munge-symlinks': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/nameconvert': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/rrsync': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/rsync-no-vanished': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/rsync-slash-strip': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/rsyncstats': No such file or directory
ls: cannot access '/usr/share/doc/rsync/support/savetransfer.c': No such file or directory
ls: cannot access '/usr/share/doc/rsync/tech_report.tex': No such file or directory
ls: cannot access '/usr/share/man/man1/rsync-ssl.1.gz': No such file or directory
ls: cannot access '/usr/share/man/man1/rsync.1.gz': No such file or directory
ls: cannot access '/usr/share/man/man5/rsyncd.conf.5.gz': No such file or directory

欠落したドキュメント類のファイルを再インストールする。

$ sudo dnf reinstall --setopt=tsflags='' rsync -y
Last metadata expiration check: 1:06:07 ago on 2021年03月25日 04時51分25秒.
Dependencies resolved.
====================================================================================================
 Package             Architecture         Version                       Repository             Size
====================================================================================================
Reinstalling:
 rsync               x86_64               3.2.3-3.fc33                  updates               393 k

Transaction Summary
====================================================================================================

Total download size: 393 k
Installed size: 731 k
Downloading Packages:
rsync-3.2.3-3.fc33.x86_64.rpm                                       740 kB/s | 393 kB     00:00
----------------------------------------------------------------------------------------------------
Total                                                               168 kB/s | 393 kB     00:02
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                            1/1
  Reinstalling     : rsync-3.2.3-3.fc33.x86_64                                                  1/2
  Cleanup          : rsync-3.2.3-3.fc33.x86_64                                                  2/2
  Running scriptlet: rsync-3.2.3-3.fc33.x86_64                                                  2/2
  Verifying        : rsync-3.2.3-3.fc33.x86_64                                                  1/2
  Verifying        : rsync-3.2.3-3.fc33.x86_64                                                  2/2

Reinstalled:
  rsync-3.2.3-3.fc33.x86_64

Complete!

ドキュメント類が配置されていることを確認する。

$ ls -lha $(rpm -q -d rsync)
-rw-r--r-- 1 root root   80  1月 12  2005 /usr/share/doc/rsync/support/Makefile
-rw-r--r-- 1 root root 4.0K  6月 17  2020 /usr/share/doc/rsync/support/atomic-rsync
-rw-r--r-- 1 root root 1.2K  6月 17  2020 /usr/share/doc/rsync/support/cvs2includes
-rw-r--r-- 1 root root 1005  6月 17  2020 /usr/share/doc/rsync/support/deny-rsync
-rw-r--r-- 1 root root 4.9K  6月 17  2020 /usr/share/doc/rsync/support/file-attr-restore
-rw-r--r-- 1 root root  538  6月 17  2020 /usr/share/doc/rsync/support/files-to-excludes
-rw-r--r-- 1 root root 3.8K  7月 18  2020 /usr/share/doc/rsync/support/git-set-file-times
-rw-r--r-- 1 root root 2.8K  6月 17  2020 /usr/share/doc/rsync/support/instant-rsyncd
-rw-r--r-- 1 root root 1.1K  6月 17  2020 /usr/share/doc/rsync/support/logfilter
-rw-r--r-- 1 root root 2.6K  7月 14  2020 /usr/share/doc/rsync/support/lsh
-rw-r--r-- 1 root root 1010  6月  5  2020 /usr/share/doc/rsync/support/lsh.sh
-rw-r--r-- 1 root root  633  6月 17  2020 /usr/share/doc/rsync/support/mapfrom
-rw-r--r-- 1 root root  625  6月 17  2020 /usr/share/doc/rsync/support/mapto
-rw-r--r-- 1 root root 1.9K  6月 17  2020 /usr/share/doc/rsync/support/mnt-excl
-rw-r--r-- 1 root root 1.5K  6月 17  2020 /usr/share/doc/rsync/support/munge-symlinks
-rw-r--r-- 1 root root 1.5K  8月  6  2020 /usr/share/doc/rsync/support/nameconvert
-rw-r--r-- 1 root root 7.3K  6月 28  2020 /usr/share/doc/rsync/support/rrsync
-rw-r--r-- 1 root root  275  6月 17  2020 /usr/share/doc/rsync/support/rsync-no-vanished
-rw-r--r-- 1 root root  651  6月 17  2020 /usr/share/doc/rsync/support/rsync-slash-strip
-rw-r--r-- 1 root root 8.5K  6月 17  2020 /usr/share/doc/rsync/support/rsyncstats
-rw-r--r-- 1 root root 4.5K 12月 18  2006 /usr/share/doc/rsync/support/savetransfer.c
-rw-r--r-- 1 root root  15K 11月 23  1998 /usr/share/doc/rsync/tech_report.tex
-rw-r--r-- 1 root root 1.8K  8月  7  2020 /usr/share/man/man1/rsync-ssl.1.gz
-rw-r--r-- 1 root root  63K 12月  8 20:57 /usr/share/man/man1/rsync.1.gz
-rw-r--r-- 1 root root  20K 12月  8 20:57 /usr/share/man/man5/rsyncd.conf.5.gz

パッケージのダウングレード

リポジトリにある有効なパッケージのすべてのバージョンを表示するには以下の様にする。

$ dnf --showduplicates list openssl
インストール済みパッケージ
openssl.x86_64                    1:1.1.1a-1.fc29                                @updates
利用可能なパッケージ
openssl.x86_64                    1:1.1.1-3.fc29                                 fedora  
openssl.x86_64                    1:1.1.1a-1.fc29                                @updates

ダウングレードするにはパッケージバージョンを直接指定する。

$ sudo dnf install openssl-1.1.1-3.fc29
メタデータの期限切れの最終確認: 0:12:46 時間前の 2019年02月11日 16時44分51秒 に実施しました。
依存関係が解決しました。
========================================================================================
 パッケージ           アーキテクチャー   バージョン                   リポジトリ         サイズ
========================================================================================
ダウングレード:
 curl                 x86_64       7.61.1-2.fc29                fedora             311 k
 libcurl              i686         7.61.1-2.fc29                fedora             272 k
 libcurl              x86_64       7.61.1-2.fc29                fedora             246 k
 libcurl-devel        x86_64       7.61.1-2.fc29                fedora             783 k
 openssl              x86_64       1:1.1.1-3.fc29               fedora             612 k
 openssl-devel        x86_64       1:1.1.1-3.fc29               fedora             2.2 M
 openssl-libs         i686         1:1.1.1-3.fc29               fedora             1.3 M
 openssl-libs         x86_64       1:1.1.1-3.fc29               fedora             1.3 M

トランザクションの概要
========================================================================================
ダウングレード  8 パッケージ

ダウンロードサイズの合計: 7.1 M
これでよろしいですか? [y/N]: y
パッケージのダウンロード中です:
(1/8): curl-7.61.1-2.fc29.x86_64.rpm                    143 kB/s | 311 kB     00:02    
(2/8): libcurl-7.61.1-2.fc29.i686.rpm                   120 kB/s | 272 kB     00:02    
(3/8): libcurl-7.61.1-2.fc29.x86_64.rpm                 109 kB/s | 246 kB     00:02    
(4/8): libcurl-devel-7.61.1-2.fc29.x86_64.rpm           2.0 MB/s | 783 kB     00:00    
(5/8): openssl-1.1.1-3.fc29.x86_64.rpm                  1.1 MB/s | 612 kB     00:00    
(6/8): openssl-libs-1.1.1-3.fc29.i686.rpm               2.1 MB/s | 1.3 MB     00:00    
(7/8): openssl-libs-1.1.1-3.fc29.x86_64.rpm             2.2 MB/s | 1.3 MB     00:00    
(8/8): openssl-devel-1.1.1-3.fc29.x86_64.rpm            1.8 MB/s | 2.2 MB     00:01    
----------------------------------------------------------------------------------------
合計                                                     2.0 MB/s | 7.1 MB     00:03     
〜省略〜

使用方法のメッセージを表示 [help] コマンド

$ dnf help
usage: dnf [options] COMMAND

主要コマンドの一覧:

alias                     List or create command aliases
autoremove                当初は依存関係としてインストールされた不要なパッケージをすべて削除します
check                     packagedb の問題を確認します
check-update              利用可能なパッケージのアップグレードを確認します
clean                     キャッシュデータを削除します
deplist                   パッケージの依存関係とこれを提供するパッケージがどれかを一覧表示します
distro-sync               インストール済みパッケージを利用可能な最新バージョンに同期します
downgrade                 パッケージをダウングレードします
group                     グループ情報を表示または使用します
help                      有用な使用方法のメッセージを表示します
history                   トランザクション履歴を表示、または使用します
info                      パッケージもしくはパッケージのグループについての詳細を表示します
install                   システムに 1 つのパッケージまたは複数のパッケージをインストールします
list                      パッケージまたはパッケージのグループを一覧表示します
makecache                 メタデータキャッシュを生成します
mark                      インストール済みパッケージをユーザーがインストールしたとマークするか、またはマークをはずします。
module                    モジュールと対話します。
provides                  どのパッケージが特定の値を提供するか見つけます
reinstall                 パッケージを再インストールします
remove                    システムから 1 つのパッケージまたは複数のパッケージを削除します
repolist                  設定済みのソフトウェアリポジトリーを表示します
repoquery                 キーワードに一致するパッケージを検索します
repository-packages       特定のリポジトリーのすべてのパッケージに対して、コマンドを実行します
search                    特定の文字列のパッケージの詳細を検索します
shell                     run an interactive DNF shell
swap                      run an interactive DNF mod for remove and install one spec
updateinfo                パッケージに関する勧告を表示します
upgrade                   システム上の 1 つのパッケージまたは複数のパッケージをアップグレードします
upgrade-minimal           システムに影響する問題を修正する「最新の」パッケージに一致したもののみをアップグレードします

プラグインコマンドの一覧

builddep                  Install build dependencies for package or spec file
changelog                 Show changelog data of packages
config-manager            manage dnf configuration options and repositories
copr                      Copr リポジトリーとの対話。
debug-dump                ファイルにインストール済みの rpm パッケージに関するダンプ情報
debug-restore             debug-dump ファイルに記録されたパッケージを復元します
debuginfo-install         debuginfo パッケージのインストール
download                  現在のディレクトリーにパッケージをダウンロードします
needs-restarting          再起動が必要な更新済みバイナリーを決定します
offline-distrosync        Prepare offline distrosync of the system
offline-upgrade           Prepare offline upgrade of the system
playground                Playground リポジトリーとの対話。
repoclosure               リポジトリーの未解決の依存関係の一覧を表示します
repodiff                  List differences between two sets of repositories
repograph                 ドット形式でパッケージの依存関係グラフ全体を出力
repomanage                rpm パッケージのディレクトリーを管理します
reposync                  リモート repo からすべてのパッケージをダウンロードします
system-upgrade            システムに新リリースにアップグレードするための準備をしてください

有用な使用方法のメッセージを表示します

General DNF options:
  -c [config file], --config [config file]
                        設定ファイルの場所
  -q, --quiet           静かな操作
  -v, --verbose         詳細な操作
  --version             show DNF version and exit
  --installroot [path]  インストール root を設定します
  --nodocs              ドキュメントをインストールしません
  --noplugins           すべてのプラグインを無効にします
  --enableplugin [plugin]
                        名前ごとにプラグインを有効にします
  --disableplugin [plugin]
                        名前ごとにプラグインを無効にします
  --releasever RELEASEVER
                        設定ファイルと repo ファイルの $releasever の値をオーバーライドします
  --setopt SETOPTS      任意の設定オプションと repo オプションを設定します
  --skip-broken         パッケージをスキップして depsolve 問題を解決します
  -h, --help, --help-cmd
                        コマンドのヘルプを表示する
  --allowerasing        依存関係を解決するために、インストール済みパッケージの消去を許可します
  -b, --best            トランザクションにおいて利用可能な最適なパッケージバージョンを試してください。
  --nobest              do not limit the transaction to the best candidate
  -C, --cacheonly       システムキャッシュから全面的に実行し、キャッシュは更新しません
  -R [minutes], --randomwait [minutes]
                        コマンドの最大待ち時間
  -d [debug level], --debuglevel [debug level]
                        出力レベルをデバッグします
  --debugsolver         ファイルに詳細な解決結果をダンプします
  --showduplicates      一覧/検索コマンドで repo の重複を表示します
  -e ERRORLEVEL, --errorlevel ERRORLEVEL
                        エラー出力レベル
  --obsoletes           enables dnf's obsoletes processing logic for upgrade
                        or display capabilities that the package obsoletes for
                        info, list and repoquery
  --rpmverbosity [debug level name]
                        rpm の出力レベルをデバッグします
  -y, --assumeyes       すべての質問に「はい」(yes) と自動的に答えます
  --assumeno            すべての質問に「いいえ」(no) と自動的に答えます
  --enablerepo [repo]   Enable additional repositories. List option. Supports
                        globs, can be specified multiple times.
  --disablerepo [repo]  Disable repositories. List option. Supports globs, can
                        be specified multiple times.
  --repo [repo], --repoid [repo]
                        id または glob により特定のリポジトリーだけを有効にします。複数回指定することが可能です
  --enable, --set-enabled
                        enable repos with config-manager command
                        (automatically saves)
  --disable, --set-disabled
                        disable repos with config-manager command
                        (automatically saves)
  -x [package], --exclude [package], --excludepkgs [package]
                        名前または glob ごとにパッケージを除外します
  --disableexcludes [repo], --disableexcludepkgs [repo]
                        excludepkgs を無効にします
  --repofrompath [repo,path]
                        label and path to an additional repository to use
                        (same path as in a baseurl), can be specified multiple
                        times.
  --noautoremove        もはや使用されていない依存関係の削除を無効にします
  --nogpgcheck          disable gpg signature checking (if RPM policy allows)
  --color COLOR         色を使うかどうか制御します
  --refresh             コマンド実行前にメタデータを期限切れに設定します
  -4                    IPv4 アドレスのみを解決します
  -6                    IPv6 アドレスのみを解決します
  --destdir DESTDIR, --downloaddir DESTDIR
                        パッケージをコピーするディレクトリーを設定します
  --downloadonly        パッケージのみをダウンロードします
  --comment COMMENT     トランザクションにコメントを追加します
  --bugfix              バグ修正関連パッケージを更新に含めます
  --enhancement         機能拡張関連パッケージを更新に含めます
  --newpackage          newpackage の関連パッケージを更新に含めます
  --security            セキュリティー関連パッケージを更新に含めます
  --advisory ADVISORY, --advisories ADVISORY
                        特定のアドバイザリーの修正に必要なパッケージを更新に含めます
  --bz BUGZILLA, --bzs BUGZILLA
                        特定の BZ の修正に必要なパッケージを更新に含めます
  --cve CVES, --cves CVES
                        特定の CVE の修正に必要なパッケージを更新に含めます
  --sec-severity {Critical,Important,Moderate,Low}, --secseverity {Critical,Important,Moderate,Low}
                        深刻度に一致するセキュリティー関連パッケージを更新に含めます
  --forcearch ARCH      アーキテクチャーの使用を強制します

パッケージ管理 [rpm]

インストール済パッケージの一覧表示

$ rpm -qa

grep との組み合わせ

$ rpm -qa | grep kernel
kernel-headers-2.6.19-1.2911.fc6
kernel-2.6.19-1.2911.fc6
kernel-devel-2.6.19-1.2911.fc6

インストール

$ rpm -ivh filename.rpm

vhオプションは処理状況を表示する。

アップデート

$ rpm -Uvh filename.rpm

アンインストール

$ rpm -e filename.rpm

パッケージに含まれるファイルの一覧表示

$ rpm -ql phpMyAdmin
/etc/httpd/conf.d/phpMyAdmin.conf
/etc/phpMyAdmin
/etc/phpMyAdmin/config.inc.php
/usr/share/doc/phpMyAdmin-2.11.11.1
/usr/share/doc/phpMyAdmin-2.11.11.1/CREDITS
/usr/share/doc/phpMyAdmin-2.11.11.1/Documentation.txt
〜省略〜

パッケージの詳細情報を表示

$ rpm -qi python
Name        : python                       Relocations: (not relocatable)
Version     : 2.4.3                             Vendor: CentOS
Release     : 27.el5_5.3                    Build Date: 2010年11月12日 03時36分24秒
Install Date: 2010年12月17日 17時52分09秒      Build Host: builder10.centos.org
Group       : Development/Languages         Source RPM: python-2.4.3-27.el5_5.3.src.rpm
Size        : 22130370                         License: PSF - see LICENSE
Signature   : DSA/SHA1, 2010年11月12日 09時22分06秒, Key ID a8a447dce8562897
URL         : http://www.python.org/
Summary     : 対話式、オブジェクト指向のインタープリタ言語
Description :
Python is an interpreted, interactive, object-oriented programming
language often compared to Tcl, Perl, Scheme or Java. Python includes
modules, classes, exceptions, very high level dynamic data types and
dynamic typing. Python supports interfaces to many system calls and
libraries, as well as to various windowing systems (X11, Motif, Tk,
Mac and MFC).

Programmers can write new built-in modules for Python in C or C++.
Python can be used as an extension language for applications that need
a programmable interface. This package contains most of the standard
Python modules, as well as modules for interfacing to the Tix widget
set for Tk and RPM.

Note that documentation for Python is provided in the python-docs
package.

強制インストール

$ sudo rpm -ivh --force --nodeps {ファイル名}:強制インストール(新規インストール & 依存関係無視)

強制削除

$ sudo rpm -ev --nodeps NetworkManager-glib.x86_64

rpm データベースにインポート済みの公開鍵一覧

$ rpm -q gpg-pubkey --qf '%{name}-%{version}-%{release} %{summary}\n'
gpg-pubkey-34ec9cba-54e38751 gpg(Fedora (23) <fedora-23-primary@fedoraproject.org>)
gpg-pubkey-00f97f56-467e318a gpg(Remi Collet <RPMS@FamilleCollet.com>)
gpg-pubkey-7fac5991-4615767f gpg(Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>)
gpg-pubkey-e051b67e-54863278 gpg(RPM Fusion free repository for Fedora (23) <rpmfusion-buildsys@lists.rpmfusion.org>)
gpg-pubkey-5ca6c469-548632d2 gpg(RPM Fusion nonfree repository for Fedora (23) <rpmfusion-buildsys@lists.rpmfusion.org>)
gpg-pubkey-5c37d3be-51687863 gpg(cudatools <cudatools@nvidia.com>)
gpg-pubkey-fdb19c98-56fd6333 gpg(Fedora 25 Primary (25) <fedora-25-primary@fedoraproject.org>)
gpg-pubkey-fa7a179a-562bcd6e gpg(RPM Fusion nonfree repository for Fedora (25) <rpmfusion-buildsys@lists.rpmfusion.org>)
gpg-pubkey-6806a9cb-562bce39 gpg(RPM Fusion free repository for Fedora (25) <rpmfusion-buildsys@lists.rpmfusion.org>)
gpg-pubkey-d38b4796-570c8cd3 gpg(Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>)
gpg-pubkey-f5282ee4-58ac92a3 gpg(Fedora 27 (27) <fedora-27@fedoraproject.org>)
gpg-pubkey-b9c13282-582f265a gpg(RPM Fusion nonfree repository for Fedora (27) <rpmfusion-buildsys@lists.rpmfusion.org>)
gpg-pubkey-7d838377-582f2494 gpg(RPM Fusion free repository for Fedora (27) <rpmfusion-buildsys@lists.rpmfusion.org>)
gpg-pubkey-09eab3f2-595fbba3 gpg(RPM Fusion free repository for Fedora (28) <rpmfusion-buildsys@lists.rpmfusion.org>)
gpg-pubkey-9db62fb1-59920156 gpg(Fedora 28 (28) <fedora-28@fedoraproject.org>)
gpg-pubkey-429476b4-5a886537 gpg(Fedora 29 (29) <fedora-29@fedoraproject.org>)
gpg-pubkey-5f11735a-5a58bcd7 gpg(Remi's RPM repository <remi@remirepo.net>)

rpm データベースに公開鍵をインポート

$ sudo rpm --import RPM-GPG-KEY-tomoyan-29

パッケージ管理 [apt]

インストール

$ sudo apt-get install package_name

コマンド / ファイル検索

$ sudo apt-get install apt-file
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libapt-pkg-perl libexporter-tiny-perl libgdbm-compat4 libgdbm6 liblist-moreutils-perl
  libperl5.28 libregexp-assemble-perl perl perl-modules-5.28
Suggested packages:
  gdbm-l10n perl-doc libterm-readline-gnu-perl | libterm-readline-perl-perl make libb-debug-perl
  liblocale-codes-perl
Recommended packages:
  netbase
The following NEW packages will be installed:
  apt-file libapt-pkg-perl libexporter-tiny-perl libgdbm-compat4 libgdbm6 liblist-moreutils-perl
  libperl5.28 libregexp-assemble-perl perl perl-modules-5.28
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 6,650 kB of archives.
After this operation, 40.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf perl-modules-5.28 all 5.28.1-6 [2,873 kB]
Get:2 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf libgdbm6 armhf 1.18.1-4 [61.1 kB]
Get:3 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf libgdbm-compat4 armhf 1.18.1-4 [43.7 kB]
Get:4 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf libperl5.28 armhf 5.28.1-6 [3,180 kB]
Get:5 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf perl armhf 5.28.1-6 [204 kB]
Get:6 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf libapt-pkg-perl armhf 0.1.34+b1 [65.9 kB]
Get:7 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf libexporter-tiny-perl all 1.002001-1 [36.9 kB]
Get:8 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf liblist-moreutils-perl armhf 0.416-1+b3 [59.6 kB]
Get:9 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf libregexp-assemble-perl all 0.36-1 [86.6 kB]
Get:10 http://ftp.tsukuba.wide.ad.jp/Linux/raspbian/raspbian buster/main armhf apt-file all 3.2.2 [38.5 kB]
Fetched 6,650 kB in 8s (861 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package perl-modules-5.28.
(Reading database ... 24226 files and directories currently installed.)
Preparing to unpack .../0-perl-modules-5.28_5.28.1-6_all.deb ...
Unpacking perl-modules-5.28 (5.28.1-6) ...
Selecting previously unselected package libgdbm6:armhf.
Preparing to unpack .../1-libgdbm6_1.18.1-4_armhf.deb ...
Unpacking libgdbm6:armhf (1.18.1-4) ...
Selecting previously unselected package libgdbm-compat4:armhf.
Preparing to unpack .../2-libgdbm-compat4_1.18.1-4_armhf.deb ...
Unpacking libgdbm-compat4:armhf (1.18.1-4) ...
Selecting previously unselected package libperl5.28:armhf.
Preparing to unpack .../3-libperl5.28_5.28.1-6_armhf.deb ...
Unpacking libperl5.28:armhf (5.28.1-6) ...
Selecting previously unselected package perl.
Preparing to unpack .../4-perl_5.28.1-6_armhf.deb ...
Unpacking perl (5.28.1-6) ...
Selecting previously unselected package libapt-pkg-perl.
Preparing to unpack .../5-libapt-pkg-perl_0.1.34+b1_armhf.deb ...
Unpacking libapt-pkg-perl (0.1.34+b1) ...
Selecting previously unselected package libexporter-tiny-perl.
Preparing to unpack .../6-libexporter-tiny-perl_1.002001-1_all.deb ...
Unpacking libexporter-tiny-perl (1.002001-1) ...
Selecting previously unselected package liblist-moreutils-perl.
Preparing to unpack .../7-liblist-moreutils-perl_0.416-1+b3_armhf.deb ...
Unpacking liblist-moreutils-perl (0.416-1+b3) ...
Selecting previously unselected package libregexp-assemble-perl.
Preparing to unpack .../8-libregexp-assemble-perl_0.36-1_all.deb ...
Unpacking libregexp-assemble-perl (0.36-1) ...
Selecting previously unselected package apt-file.
Preparing to unpack .../9-apt-file_3.2.2_all.deb ...
Unpacking apt-file (3.2.2) ...
Setting up perl-modules-5.28 (5.28.1-6) ...
Setting up libapt-pkg-perl (0.1.34+b1) ...
Setting up libgdbm6:armhf (1.18.1-4) ...
Setting up libgdbm-compat4:armhf (1.18.1-4) ...
Setting up libperl5.28:armhf (5.28.1-6) ...
Setting up perl (5.28.1-6) ...
Setting up libexporter-tiny-perl (1.002001-1) ...
Setting up libregexp-assemble-perl (0.36-1) ...
Setting up liblist-moreutils-perl (0.416-1+b3) ...
Setting up apt-file (3.2.2) ...
The system-wide cache is empty. You may want to run 'apt-file update'
as root to update the cache.
Processing triggers for libc-bin (2.28-10+rpi1) ...
$ sudo apt-file update
Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:2 https://archive.raspberrypi.org/debian buster InRelease [32.8 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf Contents (deb) [39.8 MB]
Get:4 https://archive.raspberrypi.org/debian buster/main armhf Packages [367 kB]
Get:5 https://archive.raspberrypi.org/debian buster/main armhf Contents (deb) [1,853 kB]
Get:6 http://raspbian.raspberrypi.org/raspbian buster/contrib armhf Contents (deb) [211 kB]
Get:7 http://raspbian.raspberrypi.org/raspbian buster/non-free armhf Contents (deb) [780 kB]
Fetched 43.0 MB in 4min 5s (176 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.

インストールパスに一致するパターンで検索

$ apt-file search [command_name]

インストールパスに一致する正規表現パターンで検索

$ apt-file search --regexp [regex_pattern]

使用例

$ apt-file search --regexp '/service$'
$ apt-file search /service
Finding relevant cache files to search ...
Searching, found 19720 results so far ...
debbugs: /usr/lib/debbugs/service
elpa-yasnippet-snippets: /usr/share/yasnippet-snippets/chef-mode/service
freedombox: /usr/share/plinth/actions/service
init-system-helpers: /usr/sbin/service
ircii: /usr/share/ircII/help/load/service
ircii: /usr/share/ircII/help/note/service
ircii: /usr/share/ircII/script/service
pm-utils: /usr/lib/pm-utils/bin/service
runit: /etc/service
scrollz: /usr/share/scrollz/help/note/service

インストール済パッケージの一覧表示

$ dpkg -l
要望=(U)不明/(I)インストール/(R)削除/(P)完全削除/(H)保持
| 状態=(N)無/(I)インストール済/(C)設定/(U)展開/(F)設定失敗/(H)半インストール/(W)トリガ待ち/(T)トリガ
|/ エラー?=(空欄)無/(R)要再インストール (状態,エラーの大文字=異常)
||/ 名前                                   バージョン                          アーキテクチ 説明
+++-======================================-===================================-============-========
ii  adduser                                3.118                               all          add and
ii  adwaita-icon-theme                     3.30.1-1                            all          default
ii  agnostics                              0.6                                 armhf        Raspberr
ii  aiy-board-info                         1.0-1                               all          AIY Kit
ii  aiy-bt-prov-server                     1.2-1                               all          AIY Blue
ii  aiy-cwc-server                         1.0-1                               all          AIY Codi
ii  aiy-dkms                               2.0-1                               all          Hardware
ii  aiy-io-mcu-firmware                    1.0-1                               all          AIY MCU
ii  aiy-models                             1.1-0                               all          Binary m
ii  aiy-overlay-vision                     1.0-1                               all          Device t
ii  aiy-overlay-voice                      1.0-1                               all          Device t
ii  aiy-python-wheels                      1.4-1                               all          Prebuilt
ii  aiy-usb-gadget                         1.0-1                               all          AIY USB
ii  aiy-vision-dkms                        1.2-1                               all          AIY Visi
ii  aiy-vision-firmware                    1.2-0                               all          Binary f
ii  aiy-voice-services                     1.1-1                               all          AIY Voic
ii  aiy-voicebonnet-soundcard-dkms         3.0-1                               all          AIY Voic
ii  alacarte                               3.11.91-4+rpt2                      all          easy GNO
ii  alsa-utils                             1.1.8-2                             armhf        Utilitie
ii  apt                                    1.8.2.2                             armhf        commandl
ii  apt-listchanges                        3.19                                all          package
ii  apt-utils                              1.8.2.2                             armhf        package
ii  arandr                                 0.1.9-2+rpt14                       all          Simple v
ii  aspell                                 0.60.7~20110707-6                   armhf        GNU Aspe
ii  aspell-en                              2018.04.16-0-1                      all          English
ii  attr                                   1:2.4.48-4                          armhf        utilitie
ii  avahi-daemon                           0.7-4+b1                            armhf        Avahi mD
ii  avahi-utils                            0.7-4+b1                            armhf        Avahi br
ii  base-files                             10.3+rpi1+deb10u7                   armhf        Debian b

Raspberry Pi でドライバの対応状況の関係で Kernel アップデートを保留する方法

raspberrypi-kernel パッケージの更新を保留に設定する。

$ sudo apt-mark hold raspberrypi-kernel
raspberrypi-kernel は保留に設定されました。

保留していないパッケージの更新。

$ sudo apt-get update
$ sudo apt-get upgrade
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
アップグレードパッケージを検出しています... 完了
以下のパッケージは保留されます:
  raspberrypi-kernel
アップグレード: 0 個、新規インストール: 0 個、削除: 0 個、保留: 1 個。

保留を解除する場合は以下を実行する。

$ sudo apt-mark unhold raspberrypi-kernel
raspberrypi-kernel の保留を解除しました。

パッケージの .conf を含むすべてのファイルをパージ

apt-get remove では、.conf などの設定ファイルが削除されないので、dpkg コマンドでパージする必要がある。

$ sudo apt-get remove samba samba-common smbclient
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  attr ibverbs-providers libarchive13 libavahi-client3 libboost-atomic1.67.0
  libboost-iostreams1.67.0 libboost-regex1.67.0 libboost-system1.67.0 libboost-thread1.67.0
  libcephfs2 libcups2 libgfapi0 libgfrpc0 libgfxdr0 libglusterfs0 libgpgme11 libibverbs1
  libjansson4 libldb1 libnspr4 libnss3 libpython2.7 librados2 libsmbclient libtdb1 libtevent0
  python-crypto python-dnspython python-gpg python-ldb python-samba python-talloc python-tdb
  samba-dsdb-modules samba-libs samba-vfs-modules tdb-tools
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  samba samba-common samba-common-bin smbclient
0 upgraded, 0 newly installed, 4 to remove and 28 not upgraded.
After this operation, 19.2 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 41618 files and directories currently installed.)
Removing samba (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Removing smbclient (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Removing samba-common-bin (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Removing samba-common (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...
$ sudo apt-get --purge autoremove
The following packages will be REMOVED:
  attr* ibverbs-providers* libarchive13* libavahi-client3* libboost-atomic1.67.0*
  libboost-iostreams1.67.0* libboost-regex1.67.0* libboost-system1.67.0* libboost-thread1.67.0*
  libcephfs2* libcups2* libgfapi0* libgfrpc0* libgfxdr0* libglusterfs0* libgpgme11* libibverbs1*
  libjansson4* libldb1* libnspr4* libnss3* libpython2.7* librados2* libsmbclient* libtdb1*
  libtevent0* python-crypto* python-dnspython* python-gpg* python-ldb* python-samba*
  python-talloc* python-tdb* samba-dsdb-modules* samba-libs* samba-vfs-modules* tdb-tools*
0 upgraded, 0 newly installed, 37 to remove and 28 not upgraded.
After this operation, 84.7 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 41331 files and directories currently installed.)
Removing attr (1:2.4.48-4) ...
Removing ibverbs-providers:armhf (22.1-1) ...
Removing libarchive13:armhf (3.3.3-4+deb10u1) ...
Removing samba-vfs-modules:armhf (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Removing samba-dsdb-modules:armhf (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Removing libcephfs2:armhf (12.2.11+dfsg1-2.1+rpi1) ...
Removing librados2:armhf (12.2.11+dfsg1-2.1+rpi1) ...
Removing libboost-thread1.67.0:armhf (1.67.0-13+deb10u1) ...
Removing libboost-atomic1.67.0:armhf (1.67.0-13+deb10u1) ...
Removing libboost-iostreams1.67.0:armhf (1.67.0-13+deb10u1) ...
Removing libboost-regex1.67.0:armhf (1.67.0-13+deb10u1) ...
Removing libboost-system1.67.0:armhf (1.67.0-13+deb10u1) ...
Removing libgfapi0:armhf (5.5-3) ...
Removing libgfrpc0:armhf (5.5-3) ...
Removing libgfxdr0:armhf (5.5-3) ...
Removing libglusterfs0:armhf (5.5-3) ...
Removing python-gpg (1.12.0-6) ...
Removing libgpgme11:armhf (1.12.0-6) ...
Removing libibverbs1:armhf (22.1-1) ...
Removing python-samba (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Removing python-ldb (2:1.5.1+really1.4.6-3) ...
Removing libnss3:armhf (2:3.42.1-1+deb10u3) ...
Removing libnspr4:armhf (2:4.20-1) ...
Removing python-tdb (1.3.16-2+b1) ...
Removing libsmbclient:armhf (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Removing tdb-tools (1.3.16-2+b1) ...
Removing python-crypto (2.6.1-9+b1) ...
Removing python-dnspython (1.16.0-1) ...
Removing samba-libs:armhf (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
Removing libcups2:armhf (2.2.10-6+deb10u4) ...
Removing libavahi-client3:armhf (0.7-4+b1) ...
Removing libjansson4:armhf (2.12-1) ...
Removing libldb1:armhf (2:1.5.1+really1.4.6-3) ...
Removing python-talloc:armhf (2.1.14-2) ...
Removing libpython2.7:armhf (2.7.16-2+deb10u1) ...
Removing libtdb1:armhf (1.3.16-2+b1) ...
Removing libtevent0:armhf (0.9.37-1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...
(Reading database ... 40121 files and directories currently installed.)
Purging configuration files for ibverbs-providers:armhf (22.1-1) ...
$ sudo dpkg -P samba samba-common smbclient
(Reading database ... 40117 files and directories currently installed.)
Purging configuration files for samba (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
dpkg: warning: while removing samba, directory '/var/lib/samba/printers/x64' not empty so not removed
dpkg: warning: while removing samba, directory '/var/lib/samba/printers/W32X86' not empty so not removed
Purging configuration files for samba-common (2:4.9.5+dfsg-5+deb10u1+rpi1) ...
dpkg: warning: ignoring request to remove smbclient which isn't installed
Processing triggers for systemd (241-7~deb10u4+rpi1) ...

エラー: 公開鍵を利用できないため、以下の署名は検証できませんでした: NO_PUBKEY... が発生する

$ sudo apt-get update
取得:1 http://archive.raspberrypi.org/debian buster InRelease [32.9 kB]
取得:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
取得:3 https://packages.cloud.google.com/apt aiyprojects-stable InRelease [6,715 B]
取得:4 http://archive.raspberrypi.org/debian buster/main armhf Packages [376 kB]
エラー:3 https://packages.cloud.google.com/apt aiyprojects-stable InRelease
  公開鍵を利用できないため、以下の署名は検証できませんでした: NO_PUBKEY FEEA9169307EA071 NO_PUBKEY 8B57C5C2836F4BEB
取得:5 http://archive.raspberrypi.org/debian buster/main armhf Contents (deb) [1,869 kB]
2,299 kB を 16秒 で取得しました (141 kB/s)
パッケージリストを読み込んでいます... 完了
W: 署名照合中にエラーが発生しました。リポジトリは更新されず、過去のインデックスファイルが使われます
。GPG エラー: https://packages.cloud.google.com/apt aiyprojects-stable InRelease: 公開鍵を利用できないため、以下の署名は検証できませんでした: NO_PUBKEY FEEA9169307EA071 NO_PUBKEY 8B57C5C2836F4BEB
W: https://packages.cloud.google.com/apt/dists/aiyprojects-stable/InRelease の取得に失敗しました  公開鍵を利用できないため、以下の署名は検証できませんでした: NO_PUBKEY FEEA9169307EA071 NO_PUBKEY 8B57C5C2836F4BEB
W: いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。

公開鍵 NO_PUBKEY FEEA9169307EA071、NO_PUBKEY 8B57C5C2836F4BEB をインポートする

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FEEA9169307EA071
Executing: /tmp/apt-key-gpghome.yL86kKzn3b/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys FEEA9169307EA071
gpg: 鍵FEEA9169307EA071: 公開鍵"Rapture Automatic Signing Key (cloud-rapture-signing-key-2021-03-01-08_01_09.pub)"をインポートしました
gpg:           処理数の合計: 1
gpg:             インポート: 1
$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8B57C5C2836F4BEB
Executing: /tmp/apt-key-gpghome.cM9A9XqZBA/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 8B57C5C2836F4BEB
gpg: 鍵8B57C5C2836F4BEB: 公開鍵"gLinux Rapture Automatic Signing Key (//depot/google3/production/borg/cloud-rapture/keys/cloud-rapture-pubkeys/cloud-rapture-signing-key-2020-12-03-16_08_05.pub) <glinux-team@google.com>"をインポートしました
gpg:           処理数の合計: 1
gpg:             インポート: 1

更新処理を再実行する

$ sudo apt-get update
ヒット:1 http://archive.raspberrypi.org/debian buster InRelease
ヒット:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
取得:3 https://packages.cloud.google.com/apt aiyprojects-stable InRelease [6,715 B]
取得:4 https://packages.cloud.google.com/apt aiyprojects-stable/main armhf Packages [2,198 B]
8,913 B を 5秒 で取得しました (1,870 B/s)
パッケージリストを読み込んでいます... 完了
$ sudo apt-get upgrade
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
アップグレードパッケージを検出しています... 完了
以下のパッケージはアップグレードされます:
  aiy-voicebonnet-soundcard-dkms rpi-eeprom
アップグレード: 2 個、新規インストール: 0 個、削除: 0 個、保留: 0 個。
590 kB のアーカイブを取得する必要があります。
この操作後に追加で 543 kB のディスク容量が消費されます。
続行しますか? [Y/n] y
取得:1 http://archive.raspberrypi.org/debian buster/main armhf rpi-eeprom armhf 12.4-1 [557 kB]
取得:2 https://packages.cloud.google.com/apt aiyprojects-stable/main armhf aiy-voicebonnet-soundcard-dkms all 3.0-1 [33.0 kB]
590 kB を 3秒 で取得しました (188 kB/s)
changelog を読み込んでいます... 完了
(データベースを読み込んでいます ... 現在 152346 個のファイルとディレクトリがインストールされています。)
.../aiy-voicebonnet-soundcard-dkms_3.0-1_all.deb を展開する準備をしています ...

------------------------------
Deleting module version: 3.0
completely from the DKMS tree.
------------------------------
Done.
aiy-voicebonnet-soundcard-dkms (3.0-1) で (3.0-1 に) 上書き展開しています ...
.../rpi-eeprom_12.4-1_armhf.deb を展開する準備をしています ...
rpi-eeprom (12.4-1) で (12.3-1 に) 上書き展開しています ...
aiy-voicebonnet-soundcard-dkms (3.0-1) を設定しています ...
Loading new aiy-voicebonnet-soundcard-3.0 DKMS files...
It is likely that 5.10.17+ belongs to a chroot's host
Building for 5.10.17+, 5.10.17-v7+, 5.10.17-v7l+ and 5.10.17-v8+
Building initial module for 5.10.17+
Done.

snd-aiy-voicebonnet.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17+/kernel/sound/drivers/

rt5645.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17+/kernel/sound/soc/codecs/

rl6231.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17+/kernel/sound/soc/codecs/

depmod.....

DKMS: install completed.
Building initial module for 5.10.17-v7+
Done.

snd-aiy-voicebonnet.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17-v7+/kernel/sound/drivers/

rt5645.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17-v7+/kernel/sound/soc/codecs/

rl6231.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17-v7+/kernel/sound/soc/codecs/

depmod.....

DKMS: install completed.
Building initial module for 5.10.17-v7l+
Done.

snd-aiy-voicebonnet.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17-v7l+/kernel/sound/drivers/

rt5645.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17-v7l+/kernel/sound/soc/codecs/

rl6231.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.10.17-v7l+/kernel/sound/soc/codecs/

depmod.....

DKMS: install completed.
Module build for kernel 5.10.17-v8+ was skipped since the
kernel headers for this kernel does not seem to be installed.
rpi-eeprom (12.4-1) を設定しています ...
man-db (2.8.5-2) のトリガを処理しています ...

参考文献

linux/commands/package_management.txt · 最終更新: 2021/05/21 10:38 by ともやん