ユーザ用ツール

サイト用ツール


サイドバー

Top

タグ

検索タグ

メニュー


変更履歴

windows:wsl:lxrunoffline

LxRunOffline - システムドライブ外に WSL 環境を構築する方法

インストール

Scoop によるインストール。
ダウンロード元として extras バケットを追加する。

$ scoop bucket add extras
Checking repo... ok
The extras bucket was added successfully.

LxRunOffline をインストールする。

$ scoop install lxrunoffline
Installing 'lxrunoffline' (3.4.1) [64bit]
LxRunOffline-v3.4.1-msvc.zip (2.3 MB) [=======================================================================] 100%
Checking hash of LxRunOffline-v3.4.1-msvc.zip ... ok.
Extracting LxRunOffline-v3.4.1-msvc.zip ... done.
Linking ~\scoop\apps\lxrunoffline\current => ~\scoop\apps\lxrunoffline\3.4.1
Creating shim for 'LxRunOffline'.
'lxrunoffline' (3.4.1) was installed successfully!

動作確認

$ LxRunOffline
[ERROR] No action is specified.

Supported actions are:
    l, list            List all installed distributions.
    gd, get-default    Get the default distribution, which is used by bash.exe.
    sd, set-default    Set the default distribution, which is used by bash.exe.
    i, install         Install a new distribution.
    ui, uninstall      Uninstall a distribution.
    rg, register       Register an existing installation directory.
    ur, unregister     Unregister a distribution but not delete the installation directory.
    m, move            Move a distribution to a new directory.
    d, duplicate       Duplicate an existing distribution in a new directory.
    e, export          Export a distribution's filesystem to a .tar.gz file, which can be imported by the "install" command.
    r, run             Run a command in a distribution.
    di, get-dir        Get the installation directory of a distribution.
    gv, get-version    Get the filesystem version of a distribution.
    ge, get-env        Get the default environment variables of a distribution.
    se, set-env        Set the default environment variables of a distribution.
    ae, add-env        Add to the default environment variables of a distribution.
    re, remove-env     Remove from the default environment variables of a distribution.
    gu, get-uid        Get the UID of the default user of a distribution.
    su, set-uid        Set the UID of the default user of a distribution.
    gk, get-kernelcmd  Get the default kernel command line of a distribution.
    sk, set-kernelcmd  Set the default kernel command line of a distribution.
    gf, get-flags      Get some flags of a distribution. See https://docs.microsoft.com/en-us/previous-versions/windows/desktop/api/wslapi/ne-wslapi-wsl_distribution_flags for details.
    sf, set-flags      Set some flags of a distribution. See https://docs.microsoft.com/en-us/previous-versions/windows/desktop/api/wslapi/ne-wslapi-wsl_distribution_flags for details.
    s, shortcut        Create a shortcut to launch a distribution.
    ec, export-config  Export configuration of a distribution to an XML file.
    ic, import-config  Import configuration of a distribution from an XML file.
    sm, summary        Get general information of a distribution.
    version            Get version information about this LxRunOffline.exe.

インストールされているディストリビューションの確認[l, list]

$ LxRunOffline list
fedoraremix

ディストリビューションのインストール[i, install]

Home · DDoSolitary/LxRunOffline Wiki のサポートされているディストリビューションの一覧を確認してダウンロードする。

https://lxrunoffline.apphb.com/download/{distro}/{version}

ここでは 2020/04/27 現在、明日公開予定の Fedora 32 をダウンロードする。
https://lxrunoffline.apphb.com/download/fedora/32 (fedora-32-x86_64-20200607.tar.xz - 34.4 MB)

$ LxRunOffline i -n Fedora -d C:\wsl\Fedora -f fedora-32-x86_64-20200607.tar.xz

※LxRunOffline コマンドのオプション
 i, install - 新しいディストリビューションをインストール。
 -n - ディストリビューション名。
 -d - ディストリビューションのインストール先ディレクトリ。
 -f - ルートファイルシステムを含む tar ファイル。

[===============----------------------------------------------------------]
[WARNING] Love this tool? Would you like to make a donation: https://github.com/DDoSolitary/LxRunOffline/blob/master/README.md#donation

LxRunOffline コマンドでインストールされたディストリビューションの WSL のバージョンを確認

$ wsl -l -v
  NAME           STATE           VERSION
* fedoraremix    Stopped         2
  Fedora         Stopped         1

※Fedora は WSL1 でインストールされている。

Fedora を WSL1 から WSL2 に変換する。

$ wsl --set-version Fedora 2
変換中です。この処理には数分かかることがあります...
WSL 2 との主な違いについては、https://aka.ms/wsl2 を参照してください
変換が完了しました。

ディストリビューションの WSL のバージョンを確認

$ wsl -l -v
  NAME           STATE           VERSION
* fedoraremix    Stopped         2
  Fedora         Stopped         2

ディストリビューションを既定として設定

$ wsl --set-default Fedora
$ wsl -l -v
  NAME           STATE           VERSION
* Fedora         Stopped         2
  fedoraremix    Stopped         2

ディストリビューションのアンインストール[ui, uninstall]

$ LxRunOffline ui -n Fedora

※LxRunOffline コマンドのオプション
 ui, uninstall - 新しいディストリビューションをインストール。
 -n - ディストリビューション名。

WSL1 と WSL2 の並列実行

コマンドプロンプト、PowerShell から wsl コマンド、または、bash ランチャー経由で WSL を起動した場合はデフォルト(既定)の WSL 環境が起動される。
既定のディストリビューションの確認

$ wsl -l
Linux 用 Windows サブシステム ディストリビューション:
Fedora (既定)
Fedora_wsl1
fedoraremix

または

$ wsl -l -v
  NAME           STATE           VERSION
* Fedora         Running         2
  Fedora-WSL1    Stopped         1
  fedoraremix    Running         2

既定のディストリビューションを変更するには以下のコマンドを実行する。

$ wsl -s fedoraremix
$ wsl -l -v
  NAME           STATE           VERSION
* fedoraremix    Running         2
  Fedora-WSL1    Stopped         1
  Fedora         Running         2

デスクトップにディストリビューションのショートカットを作成する[s, shortcut]

デスクトップにショートカットを作成する方法で WSL1 と WSL2 を並列実行できるようになる。

$ LxRunOffline l
Fedora-WSL1
fedoraremix
Fedora
$ LxRunOffline s -n "Fedora-WSL1" -f "C:\Users\tomoyan\Desktop\Fedora(WSL1).lnk"
$ LxRunOffline s -n "fedoraremix" -f "C:\Users\tomoyan\Desktop\Fedora Remix.lnk"
$ LxRunOffline s -n "Fedora" -f "C:\Users\tomoyan\Desktop\Fedora.lnk"

作成されたショートカットのリンク先は以下の内容となる。

C:\Users\tomoyan\scoop\apps\lxrunoffline\current\LxRunOffline.exe run -w -n "Fedora-WSL1"
C:\Users\tomoyan\scoop\apps\lxrunoffline\current\LxRunOffline.exe run -w -n "fedoraremix"
C:\Users\tomoyan\scoop\apps\lxrunoffline\current\LxRunOffline.exe run -w -n "Fedora"

起動済のコマンドプロンプト、PowerShell から WSL1 / WSL2 環境を実行する[r, run]

コマンドプロンプト、または、PowerShell を起動する。
そして、以下のコマンドを実行すると各 WSL 環境を実行できる。

$ LxRunOffline r -n "Fedora-WSL1"
$ LxRunOffline r -n "fedoraremix"
$ LxRunOffline r -n "Fedora"

Fedora-WSL1 (WSL1 の Fedora)
 fedoraremix (WSL2 の Fedora Remix)
 Fedora (WSL2 の Fedora)

ディストリビューションの初期設定

ディストリビューションを実行する。

$ LxRunOffline r -n "Fedora"
#

Fedora のバージョン確認。

# cat /etc/redhat-release
Fedora release 32 (Thirty Two)

WSL 2 Kernel のバージョン確認。

# uname -a
Linux Cmon 4.19.121-microsoft-standard #1 SMP Fri Jun 19 21:06:10 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

LxRunOffline でインストールできる Fedora 32 の初期パッケージ。

# dnf list installed
Installed Packages
alternatives.x86_64                    1.11-6.fc32                           @anaconda
audit-libs.x86_64                      3.0-0.19.20191104git1c2f876.fc32      @anaconda
basesystem.noarch                      11-9.fc32                             @anaconda
bash.x86_64                            5.0.17-1.fc32                         @koji-override-0
bzip2-libs.x86_64                      1.0.8-2.fc32                          @anaconda
ca-certificates.noarch                 2020.2.40-3.fc32                      @anaconda
coreutils.x86_64                       8.32-4.fc32.1                         @koji-override-0
coreutils-common.x86_64                8.32-4.fc32.1                         @koji-override-0
cracklib.x86_64                        2.9.6-22.fc32                         @anaconda
crypto-policies.noarch                 20200527-1.gitb234a47.fc32            @koji-override-0
curl.x86_64                            7.69.1-3.fc32                         @koji-override-0
cyrus-sasl-lib.x86_64                  2.1.27-4.fc32                         @anaconda
dnf.noarch                             4.2.23-1.fc32                         @koji-override-0
dnf-data.noarch                        4.2.23-1.fc32                         @koji-override-0
elfutils-default-yama-scope.noarch     0.179-2.fc32                          @koji-override-0
elfutils-libelf.x86_64                 0.179-2.fc32                          @koji-override-0
elfutils-libs.x86_64                   0.179-2.fc32                          @koji-override-0
expat.x86_64                           2.2.8-2.fc32                          @anaconda
fedora-gpg-keys.noarch                 32-2                                  @koji-override-0
fedora-release-common.noarch           32-2                                  @koji-override-0
fedora-release-container.noarch        32-2                                  @koji-override-0
fedora-repos.noarch                    32-2                                  @koji-override-0
file-libs.x86_64                       5.38-2.fc32                           @anaconda
filesystem.x86_64                      3.14-2.fc32                           @anaconda
gawk.x86_64                            5.0.1-7.fc32                          @anaconda
gdbm-libs.x86_64                       1:1.18.1-3.fc32                       @anaconda
glib2.x86_64                           2.64.3-1.fc32                         @koji-override-0
glibc.x86_64                           2.31-2.fc32                           @anaconda
glibc-common.x86_64                    2.31-2.fc32                           @anaconda
glibc-minimal-langpack.x86_64          2.31-2.fc32                           @anaconda
gmp.x86_64                             1:6.1.2-13.fc32                       @anaconda
gnupg2.x86_64                          2.2.20-2.fc32                         @koji-override-0
gnutls.x86_64                          3.6.13-6.fc32                         @koji-override-0
gpgme.x86_64                           1.13.1-7.fc32                         @koji-override-0
grep.x86_64                            3.3-4.fc32                            @anaconda
gzip.x86_64                            1.10-2.fc32                           @anaconda
ima-evm-utils.x86_64                   1.2.1-3.fc32                          @anaconda
json-c.x86_64                          0.13.1-13.fc32                        @koji-override-0
keyutils-libs.x86_64                   1.6-4.fc32                            @anaconda
krb5-libs.x86_64                       1.18-1.fc32                           @anaconda
libacl.x86_64                          2.2.53-5.fc32                         @anaconda
libarchive.x86_64                      3.4.3-1.fc32                          @koji-override-0
libassuan.x86_64                       2.5.3-3.fc32                          @anaconda
libattr.x86_64                         2.4.48-8.fc32                         @anaconda
libblkid.x86_64                        2.35.2-1.fc32                         @koji-override-0
libbrotli.x86_64                       1.0.7-10.fc32                         @anaconda
libcap.x86_64                          2.26-7.fc32                           @anaconda
libcap-ng.x86_64                       0.7.10-2.fc32                         @anaconda
libcom_err.x86_64                      1.45.5-3.fc32                         @anaconda
libcomps.x86_64                        0.1.15-1.fc32                         @koji-override-0
libcurl.x86_64                         7.69.1-3.fc32                         @koji-override-0
libdb.x86_64                           5.3.28-40.fc32                        @anaconda
libdb-utils.x86_64                     5.3.28-40.fc32                        @anaconda
libdnf.x86_64                          0.48.0-1.fc32                         @koji-override-0
libfdisk.x86_64                        2.35.2-1.fc32                         @koji-override-0
libffi.x86_64                          3.1-24.fc32                           @anaconda
libgcc.x86_64                          10.1.1-1.fc32                         @koji-override-0
libgcrypt.x86_64                       1.8.5-3.fc32                          @anaconda
libgomp.x86_64                         10.1.1-1.fc32                         @koji-override-0
libgpg-error.x86_64                    1.36-3.fc32                           @anaconda
libidn2.x86_64                         2.3.0-2.fc32                          @anaconda
libksba.x86_64                         1.3.5-11.fc32                         @anaconda
libmetalink.x86_64                     0.1.3-10.fc32                         @anaconda
libmodulemd.x86_64                     2.9.3-1.fc32                          @koji-override-0
libmount.x86_64                        2.35.2-1.fc32                         @koji-override-0
libnghttp2.x86_64                      1.41.0-1.fc32                         @koji-override-0
libnsl2.x86_64                         1.2.0-6.20180605git4a062cf.fc32       @anaconda
libpsl.x86_64                          0.21.0-4.fc32                         @anaconda
libpwquality.x86_64                    1.4.2-2.fc32                          @anaconda
librepo.x86_64                         1.12.0-1.fc32                         @koji-override-0
libreport-filesystem.noarch            2.13.1-4.fc32                         @koji-override-0
libselinux.x86_64                      3.0-3.fc32                            @anaconda
libsemanage.x86_64                     3.0-3.fc32                            @anaconda
libsepol.x86_64                        3.0-3.fc32                            @anaconda
libsigsegv.x86_64                      2.11-10.fc32                          @anaconda
libsmartcols.x86_64                    2.35.2-1.fc32                         @koji-override-0
libsolv.x86_64                         0.7.14-1.fc32                         @koji-override-0
libssh.x86_64                          0.9.4-2.fc32                          @koji-override-0
libssh-config.noarch                   0.9.4-2.fc32                          @koji-override-0
libsss_idmap.x86_64                    2.3.0-1.fc32                          @koji-override-0
libsss_nss_idmap.x86_64                2.3.0-1.fc32                          @koji-override-0
libstdc++.x86_64                       10.1.1-1.fc32                         @koji-override-0
libtasn1.x86_64                        4.16.0-1.fc32                         @anaconda
libtirpc.x86_64                        1.2.6-0.fc32                          @koji-override-0
libunistring.x86_64                    0.9.10-7.fc32                         @anaconda
libusbx.x86_64                         1.0.23-1.fc32                         @anaconda
libutempter.x86_64                     1.1.6-18.fc32                         @anaconda
libuuid.x86_64                         2.35.2-1.fc32                         @koji-override-0
libverto.x86_64                        0.3.0-9.fc32                          @anaconda
libxcrypt.x86_64                       4.4.16-3.fc32                         @koji-override-0
libxml2.x86_64                         2.9.10-3.fc32                         @anaconda
libyaml.x86_64                         0.2.2-3.fc32                          @anaconda
libzstd.x86_64                         1.4.5-3.fc32                          @koji-override-0
lua-libs.x86_64                        5.3.5-7.fc32                          @anaconda
lz4-libs.x86_64                        1.9.1-2.fc32                          @anaconda
mpfr.x86_64                            4.0.2-4.fc32                          @koji-override-0
ncurses.x86_64                         6.1-15.20191109.fc32                  @anaconda
ncurses-base.noarch                    6.1-15.20191109.fc32                  @anaconda
ncurses-libs.x86_64                    6.1-15.20191109.fc32                  @anaconda
nettle.x86_64                          3.5.1-5.fc32                          @anaconda
npth.x86_64                            1.6-4.fc32                            @anaconda
openldap.x86_64                        2.4.47-4.fc32                         @anaconda
openssl.x86_64                         1:1.1.1g-1.fc32                       @koji-override-0
openssl-libs.x86_64                    1:1.1.1g-1.fc32                       @koji-override-0
p11-kit.x86_64                         0.23.20-1.fc32                        @anaconda
p11-kit-trust.x86_64                   0.23.20-1.fc32                        @anaconda
pam.x86_64                             1.3.1-24.fc32                         @anaconda
pcre.x86_64                            8.44-1.fc32                           @anaconda
pcre2.x86_64                           10.35-1.fc32                          @koji-override-0
pcre2-syntax.noarch                    10.35-1.fc32                          @koji-override-0
popt.x86_64                            1.16-19.fc32                          @anaconda
publicsuffix-list-dafsa.noarch         20190417-3.fc32                       @anaconda
python-pip-wheel.noarch                19.3.1-3.fc32                         @koji-override-0
python-setuptools-wheel.noarch         41.6.0-2.fc32                         @anaconda
python3.x86_64                         3.8.3-1.fc32                          @koji-override-0
python3-dnf.noarch                     4.2.23-1.fc32                         @koji-override-0
python3-gpg.x86_64                     1.13.1-7.fc32                         @koji-override-0
python3-hawkey.x86_64                  0.48.0-1.fc32                         @koji-override-0
python3-libcomps.x86_64                0.1.15-1.fc32                         @koji-override-0
python3-libdnf.x86_64                  0.48.0-1.fc32                         @koji-override-0
python3-libs.x86_64                    3.8.3-1.fc32                          @koji-override-0
python3-rpm.x86_64                     4.15.1-3.fc32.1                       @koji-override-0
readline.x86_64                        8.0-4.fc32                            @anaconda
rootfiles.noarch                       8.1-27.fc32                           @anaconda
rpm.x86_64                             4.15.1-3.fc32.1                       @koji-override-0
rpm-build-libs.x86_64                  4.15.1-3.fc32.1                       @koji-override-0
rpm-libs.x86_64                        4.15.1-3.fc32.1                       @koji-override-0
rpm-sign-libs.x86_64                   4.15.1-3.fc32.1                       @koji-override-0
sed.x86_64                             4.5-5.fc32                            @anaconda
setup.noarch                           2.13.6-2.fc32                         @anaconda
shadow-utils.x86_64                    2:4.8.1-2.fc32                        @anaconda
sqlite-libs.x86_64                     3.32.1-1.fc32                         @koji-override-0
sssd-client.x86_64                     2.3.0-1.fc32                          @koji-override-0
sudo.x86_64                            1.9.0-0.1.b4.fc32                     @anaconda
systemd-libs.x86_64                    245.6-2.fc32                          @koji-override-0
tar.x86_64                             2:1.32-4.fc32                         @anaconda
tss2.x86_64                            1331-4.fc32                           @anaconda
tzdata.noarch                          2020a-1.fc32                          @koji-override-0
util-linux.x86_64                      2.35.2-1.fc32                         @koji-override-0
vim-minimal.x86_64                     2:8.2.869-1.fc32                      @koji-override-0
xz-libs.x86_64                         5.2.5-1.fc32                          @anaconda
yum.noarch                             4.2.23-1.fc32                         @koji-override-0
zchunk-libs.x86_64                     1.1.5-2.fc32                          @anaconda
zlib.x86_64                            1.2.11-21.fc32                        @anaconda

passwd コマンドのインストールを行う。

# dnf install passwd cracklib-dicts
Fedora 32 openh264 (From Cisco) - x86_64                                    1.8 kB/s | 5.1 kB     00:02
Fedora Modular 32 - x86_64                                                  1.4 MB/s | 4.9 MB     00:03
Fedora Modular 32 - x86_64 - Updates                                        543 kB/s | 3.5 MB     00:06
Fedora 32 - x86_64 - Updates                                                1.2 MB/s |  17 MB     00:14
Fedora 32 - x86_64                                                          1.9 MB/s |  70 MB     00:36
Dependencies resolved.
=============================================================================================
 Package                  Architecture     Version                    Repository        Size
=============================================================================================
Installing:
 cracklib-dicts           x86_64           2.9.6-22.fc32              fedora           3.7 M
 passwd                   x86_64           0.80-8.fc32                fedora           109 k
Installing dependencies:
 libuser                  x86_64           0.62-24.fc32               fedora           384 k

Transaction Summary
=============================================================================================
Install  3 Packages

Total download size: 4.1 M
Installed size: 12 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): passwd-0.80-8.fc32.x86_64.rpm                         212 kB/s | 109 kB     00:00
(2/3): libuser-0.62-24.fc32.x86_64.rpm                       453 kB/s | 384 kB     00:00
(3/3): cracklib-dicts-2.9.6-22.fc32.x86_64.rpm               1.6 MB/s | 3.7 MB     00:02
---------------------------------------------------------------------------------------------
Total                                                        1.2 MB/s | 4.1 MB     00:03
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                     1/1
  Installing       : libuser-0.62-24.fc32.x86_64                                         1/3
  Installing       : passwd-0.80-8.fc32.x86_64                                           2/3
  Installing       : cracklib-dicts-2.9.6-22.fc32.x86_64                                 3/3
  Running scriptlet: cracklib-dicts-2.9.6-22.fc32.x86_64                                 3/3
  Verifying        : cracklib-dicts-2.9.6-22.fc32.x86_64                                 1/3
  Verifying        : libuser-0.62-24.fc32.x86_64                                         2/3
  Verifying        : passwd-0.80-8.fc32.x86_64                                           3/3

Installed:
  cracklib-dicts-2.9.6-22.fc32.x86_64 libuser-0.62-24.fc32.x86_64 passwd-0.80-8.fc32.x86_64

Complete!

デフォルトログインユーザーの作成。

# adduser tomoyan
# usermod -G wheel tomoyan
# passwd tomoyan
Changing password for user tomoyan.
New password:
Retype new password:
passwd: all authentication tokens updated successfully.
# id tomoyan
uid=1000(tomoyan) gid=1000(tomoyan) groups=1000(tomoyan),10(wheel)

WSL からログアウトする。

# exit
logout

ディストリビューションのデフォルトユーザーを設定する[su, set-uid]

$ LxRunOffline su -n "Fedora" -v 1000

デフォルトユーザーの UID を確認する。

LxRunOffline gu -n "Fedora"
1000

ディストリビューションを起動する。

$ LxRunOffline r -n "Fedora"
[tomoyan@Cmon tomoyan]$

systemd のインストール

$ sudo dnf install systemd
Last metadata expiration check: 0:44:23 ago on Sat Jun 27 06:47:25 2020.
Dependencies resolved.
=============================================================================================
 Package                       Architecture  Version                    Repository      Size
=============================================================================================
Installing:
 systemd                       x86_64        245.6-2.fc32               updates        4.2 M
Installing dependencies:
 acl                           x86_64        2.2.53-5.fc32              fedora          72 k
 cryptsetup-libs               x86_64        2.3.3-1.fc32               updates        470 k
 dbus                          x86_64        1:1.12.18-1.fc32           updates        9.7 k
 dbus-broker                   x86_64        23-2.fc32                  updates        175 k
 dbus-common                   noarch        1:1.12.18-1.fc32           updates         16 k
 device-mapper                 x86_64        1.02.171-1.fc32            fedora         143 k
 device-mapper-libs            x86_64        1.02.171-1.fc32            fedora         180 k
 iptables-libs                 x86_64        1.8.4-7.fc32               fedora         368 k
 kmod-libs                     x86_64        27-1.fc32                  fedora          64 k
 libargon2                     x86_64        20171227-4.fc32            fedora          30 k
 libmnl                        x86_64        1.0.4-11.fc32              fedora          28 k
 libnetfilter_conntrack        x86_64        1.0.7-4.fc32               fedora          62 k
 libnfnetlink                  x86_64        1.0.1-17.fc32              fedora          29 k
 libpcap                       x86_64        14:1.9.1-3.fc32            fedora         172 k
 libseccomp                    x86_64        2.4.2-3.fc32               fedora          84 k
 qrencode-libs                 x86_64        4.0.2-5.fc32               fedora          60 k
 systemd-pam                   x86_64        245.6-2.fc32               updates        299 k
 systemd-rpm-macros            noarch        245.6-2.fc32               updates         25 k
 xkeyboard-config              noarch        2.29-1.fc32                fedora         772 k
Installing weak dependencies:
 diffutils                     x86_64        3.7-4.fc32                 fedora         397 k
 libxkbcommon                  x86_64        0.10.0-2.fc32              fedora         121 k

Transaction Summary
=============================================================================================
Install  22 Packages

Total download size: 7.7 M
Installed size: 28 M
Is this ok [y/N]: y
Downloading Packages:
(1/22): dbus-1.12.18-1.fc32.x86_64.rpm                        74 kB/s | 9.7 kB     00:00
(2/22): dbus-common-1.12.18-1.fc32.noarch.rpm                257 kB/s |  16 kB     00:00
(3/22): dbus-broker-23-2.fc32.x86_64.rpm                     345 kB/s | 175 kB     00:00
(4/22): cryptsetup-libs-2.3.3-1.fc32.x86_64.rpm              555 kB/s | 470 kB     00:00
(5/22): systemd-rpm-macros-245.6-2.fc32.noarch.rpm           280 kB/s |  25 kB     00:00
(6/22): systemd-pam-245.6-2.fc32.x86_64.rpm                  677 kB/s | 299 kB     00:00
(7/22): acl-2.2.53-5.fc32.x86_64.rpm                         298 kB/s |  72 kB     00:00
(8/22): device-mapper-1.02.171-1.fc32.x86_64.rpm             425 kB/s | 143 kB     00:00
(9/22): device-mapper-libs-1.02.171-1.fc32.x86_64.rpm        677 kB/s | 180 kB     00:00
(10/22): diffutils-3.7-4.fc32.x86_64.rpm                     825 kB/s | 397 kB     00:00
(11/22): iptables-libs-1.8.4-7.fc32.x86_64.rpm               804 kB/s | 368 kB     00:00
(12/22): kmod-libs-27-1.fc32.x86_64.rpm                      433 kB/s |  64 kB     00:00
(13/22): libmnl-1.0.4-11.fc32.x86_64.rpm                     223 kB/s |  28 kB     00:00
(14/22): libargon2-20171227-4.fc32.x86_64.rpm                185 kB/s |  30 kB     00:00
(15/22): libnetfilter_conntrack-1.0.7-4.fc32.x86_64.rpm      506 kB/s |  62 kB     00:00
(16/22): libnfnetlink-1.0.1-17.fc32.x86_64.rpm               231 kB/s |  29 kB     00:00
(17/22): libseccomp-2.4.2-3.fc32.x86_64.rpm                  545 kB/s |  84 kB     00:00
(18/22): libpcap-1.9.1-3.fc32.x86_64.rpm                     709 kB/s | 172 kB     00:00
(19/22): qrencode-libs-4.0.2-5.fc32.x86_64.rpm               465 kB/s |  60 kB     00:00
(20/22): libxkbcommon-0.10.0-2.fc32.x86_64.rpm               635 kB/s | 121 kB     00:00
(21/22): systemd-245.6-2.fc32.x86_64.rpm                     1.3 MB/s | 4.2 MB     00:03
(22/22): xkeyboard-config-2.29-1.fc32.noarch.rpm             845 kB/s | 772 kB     00:00
---------------------------------------------------------------------------------------------
Total                                                        1.5 MB/s | 7.7 MB     00:05
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                     1/1
  Installing       : xkeyboard-config-2.29-1.fc32.noarch                                1/22
  Installing       : libxkbcommon-0.10.0-2.fc32.x86_64                                  2/22
  Installing       : qrencode-libs-4.0.2-5.fc32.x86_64                                  3/22
  Installing       : libseccomp-2.4.2-3.fc32.x86_64                                     4/22
  Installing       : libpcap-14:1.9.1-3.fc32.x86_64                                     5/22
  Installing       : libnfnetlink-1.0.1-17.fc32.x86_64                                  6/22
  Installing       : libmnl-1.0.4-11.fc32.x86_64                                        7/22
  Installing       : libnetfilter_conntrack-1.0.7-4.fc32.x86_64                         8/22
  Installing       : iptables-libs-1.8.4-7.fc32.x86_64                                  9/22
  Installing       : libargon2-20171227-4.fc32.x86_64                                  10/22
  Installing       : kmod-libs-27-1.fc32.x86_64                                        11/22
  Installing       : diffutils-3.7-4.fc32.x86_64                                       12/22
  Installing       : acl-2.2.53-5.fc32.x86_64                                          13/22
  Installing       : systemd-rpm-macros-245.6-2.fc32.noarch                            14/22
  Installing       : device-mapper-1.02.171-1.fc32.x86_64                              15/22
  Installing       : device-mapper-libs-1.02.171-1.fc32.x86_64                         16/22
  Installing       : cryptsetup-libs-2.3.3-1.fc32.x86_64                               17/22
  Installing       : dbus-1:1.12.18-1.fc32.x86_64                                      18/22
  Installing       : systemd-pam-245.6-2.fc32.x86_64                                   19/22
  Running scriptlet: systemd-245.6-2.fc32.x86_64                                       20/22
  Installing       : systemd-245.6-2.fc32.x86_64                                       20/22
  Running scriptlet: systemd-245.6-2.fc32.x86_64                                       20/22
  Installing       : dbus-common-1:1.12.18-1.fc32.noarch                               21/22
  Running scriptlet: dbus-common-1:1.12.18-1.fc32.noarch                               21/22
Created symlink /etc/systemd/system/sockets.target.wants/dbus.socket → /usr/lib/systemd/system/dbus.socket.
Created symlink /etc/systemd/user/sockets.target.wants/dbus.socket → /usr/lib/systemd/user/dbus.socket.

  Running scriptlet: dbus-broker-23-2.fc32.x86_64                                      22/22
  Installing       : dbus-broker-23-2.fc32.x86_64                                      22/22
  Running scriptlet: dbus-broker-23-2.fc32.x86_64                                      22/22
Created symlink /etc/systemd/system/dbus.service → /usr/lib/systemd/system/dbus-broker.service.
Created symlink /etc/systemd/user/dbus.service → /usr/lib/systemd/user/dbus-broker.service.

  Verifying        : cryptsetup-libs-2.3.3-1.fc32.x86_64                                1/22
  Verifying        : dbus-1:1.12.18-1.fc32.x86_64                                       2/22
  Verifying        : dbus-broker-23-2.fc32.x86_64                                       3/22
  Verifying        : dbus-common-1:1.12.18-1.fc32.noarch                                4/22
  Verifying        : systemd-245.6-2.fc32.x86_64                                        5/22
  Verifying        : systemd-pam-245.6-2.fc32.x86_64                                    6/22
  Verifying        : systemd-rpm-macros-245.6-2.fc32.noarch                             7/22
  Verifying        : acl-2.2.53-5.fc32.x86_64                                           8/22
  Verifying        : device-mapper-1.02.171-1.fc32.x86_64                               9/22
  Verifying        : device-mapper-libs-1.02.171-1.fc32.x86_64                         10/22
  Verifying        : diffutils-3.7-4.fc32.x86_64                                       11/22
  Verifying        : iptables-libs-1.8.4-7.fc32.x86_64                                 12/22
  Verifying        : kmod-libs-27-1.fc32.x86_64                                        13/22
  Verifying        : libargon2-20171227-4.fc32.x86_64                                  14/22
  Verifying        : libmnl-1.0.4-11.fc32.x86_64                                       15/22
  Verifying        : libnetfilter_conntrack-1.0.7-4.fc32.x86_64                        16/22
  Verifying        : libnfnetlink-1.0.1-17.fc32.x86_64                                 17/22
  Verifying        : libpcap-14:1.9.1-3.fc32.x86_64                                    18/22
  Verifying        : libseccomp-2.4.2-3.fc32.x86_64                                    19/22
  Verifying        : libxkbcommon-0.10.0-2.fc32.x86_64                                 20/22
  Verifying        : qrencode-libs-4.0.2-5.fc32.x86_64                                 21/22
  Verifying        : xkeyboard-config-2.29-1.fc32.noarch                               22/22

Installed:
  acl-2.2.53-5.fc32.x86_64                         cryptsetup-libs-2.3.3-1.fc32.x86_64
  dbus-1:1.12.18-1.fc32.x86_64                     dbus-broker-23-2.fc32.x86_64
  dbus-common-1:1.12.18-1.fc32.noarch              device-mapper-1.02.171-1.fc32.x86_64
  device-mapper-libs-1.02.171-1.fc32.x86_64        diffutils-3.7-4.fc32.x86_64
  iptables-libs-1.8.4-7.fc32.x86_64                kmod-libs-27-1.fc32.x86_64
  libargon2-20171227-4.fc32.x86_64                 libmnl-1.0.4-11.fc32.x86_64
  libnetfilter_conntrack-1.0.7-4.fc32.x86_64       libnfnetlink-1.0.1-17.fc32.x86_64
  libpcap-14:1.9.1-3.fc32.x86_64                   libseccomp-2.4.2-3.fc32.x86_64
  libxkbcommon-0.10.0-2.fc32.x86_64                qrencode-libs-4.0.2-5.fc32.x86_64
  systemd-245.6-2.fc32.x86_64                      systemd-pam-245.6-2.fc32.x86_64
  systemd-rpm-macros-245.6-2.fc32.noarch           xkeyboard-config-2.29-1.fc32.noarch

Complete!

日本語環境の設定
langpacks-ja パッケージのインストールを行う。

$ sudo dnf install langpacks-ja
Last metadata expiration check: 0:35:05 ago on Sat Jun 27 06:47:25 2020.
Dependencies resolved.
=============================================================================================
 Package                               Architecture Version               Repository    Size
=============================================================================================
Installing:
 langpacks-ja                          noarch       3.0-3.fc32            fedora       9.5 k
Installing dependencies:
 google-noto-cjk-fonts-common          noarch       20190416-6.fc32       fedora        20 k
 google-noto-sans-cjk-ttc-fonts        noarch       20190416-6.fc32       fedora        86 M
 langpacks-core-font-ja                noarch       3.0-3.fc32            fedora       9.4 k
 langpacks-core-ja                     noarch       3.0-3.fc32            fedora       9.5 k
Installing weak dependencies:
 glibc-langpack-ja                     x86_64       2.31-2.fc32           fedora       407 k
 google-noto-serif-cjk-ttc-fonts       noarch       20190416-6.fc32       fedora       108 M

Transaction Summary
=============================================================================================
Install  7 Packages

Total download size: 194 M
Installed size: 297 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): google-noto-cjk-fonts-common-20190416-6.fc32.noarch.r  73 kB/s |  20 kB     00:00
(2/7): glibc-langpack-ja-2.31-2.fc32.x86_64.rpm              473 kB/s | 407 kB     00:00
(3/7): langpacks-core-font-ja-3.0-3.fc32.noarch.rpm           90 kB/s | 9.4 kB     00:00
(4/7): langpacks-core-ja-3.0-3.fc32.noarch.rpm               120 kB/s | 9.5 kB     00:00
(5/7): langpacks-ja-3.0-3.fc32.noarch.rpm                    127 kB/s | 9.5 kB     00:00
(6/7): google-noto-sans-cjk-ttc-fonts-20190416-6.fc32.noarch 1.1 MB/s |  86 MB     01:21
(7/7): google-noto-serif-cjk-ttc-fonts-20190416-6.fc32.noarc 1.1 MB/s | 108 MB     01:36
---------------------------------------------------------------------------------------------
Total                                                        2.0 MB/s | 194 MB     01:37
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                     1/1
  Installing       : google-noto-cjk-fonts-common-20190416-6.fc32.noarch                 1/7
  Installing       : google-noto-sans-cjk-ttc-fonts-20190416-6.fc32.noarch               2/7
  Installing       : langpacks-core-font-ja-3.0-3.fc32.noarch                            3/7
  Installing       : google-noto-serif-cjk-ttc-fonts-20190416-6.fc32.noarch              4/7
  Installing       : glibc-langpack-ja-2.31-2.fc32.x86_64                                5/7
  Installing       : langpacks-core-ja-3.0-3.fc32.noarch                                 6/7
  Installing       : langpacks-ja-3.0-3.fc32.noarch                                      7/7
  Running scriptlet: langpacks-ja-3.0-3.fc32.noarch                                      7/7
  Verifying        : glibc-langpack-ja-2.31-2.fc32.x86_64                                1/7
  Verifying        : google-noto-cjk-fonts-common-20190416-6.fc32.noarch                 2/7
  Verifying        : google-noto-sans-cjk-ttc-fonts-20190416-6.fc32.noarch               3/7
  Verifying        : google-noto-serif-cjk-ttc-fonts-20190416-6.fc32.noarch              4/7
  Verifying        : langpacks-core-font-ja-3.0-3.fc32.noarch                            5/7
  Verifying        : langpacks-core-ja-3.0-3.fc32.noarch                                 6/7
  Verifying        : langpacks-ja-3.0-3.fc32.noarch                                      7/7

Installed:
  glibc-langpack-ja-2.31-2.fc32.x86_64
  google-noto-cjk-fonts-common-20190416-6.fc32.noarch
  google-noto-sans-cjk-ttc-fonts-20190416-6.fc32.noarch
  google-noto-serif-cjk-ttc-fonts-20190416-6.fc32.noarch
  langpacks-core-font-ja-3.0-3.fc32.noarch
  langpacks-core-ja-3.0-3.fc32.noarch
  langpacks-ja-3.0-3.fc32.noarch

Complete!

WSL 2 の systemd 問題
システムロケール設定を ja_JP.UTF-8 に変更する。

$ sudo localectl set-locale LANG=ja_JP.UTF-8
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to create bus connection: Host is down
システムは、initd システム (PID 1) なので systemd として起動されていません。操作できません。
バスへの接続に失敗しました: ホストがダウンしています

systemd が起動していないため、システムロケール設定を変更できない。

genie をインストールして systemd を動作させる。
git のインストールを行う。

# dnf install git
Fedora Modular 32 - x86_64 - Updates            7.0 kB/s | 5.6 kB     00:00
Fedora 32 - x86_64 - Updates                    9.2 kB/s | 5.9 kB     00:00
Dependencies resolved.
================================================================================
 Package                  Arch     Version                      Repo       Size
================================================================================
Installing:
 git                      x86_64   2.26.2-1.fc32                updates   126 k
Installing dependencies:
 emacs-filesystem         noarch   1:26.3-2.fc32                fedora    8.5 k
 git-core                 x86_64   2.26.2-1.fc32                updates   4.9 M
 git-core-doc             noarch   2.26.2-1.fc32                updates   2.2 M
 groff-base               x86_64   1.22.3-21.fc32               fedora    1.0 M
 less                     x86_64   551-3.fc32                   fedora    156 k
 libcbor                  x86_64   0.5.0-7.fc32                 fedora     46 k
 libedit                  x86_64   3.1-32.20191231cvs.fc32      fedora    106 k
 libfido2                 x86_64   1.3.1-2.fc32                 updates    65 k
 openssh                  x86_64   8.2p1-3.fc32                 updates   479 k
 openssh-clients          x86_64   8.2p1-3.fc32                 updates   654 k
 perl-Carp                noarch   1.50-440.fc32                fedora     29 k
 perl-Data-Dumper         x86_64   2.174-443.fc32               fedora     56 k
 perl-Digest              noarch   1.17-440.fc32                fedora     24 k
 perl-Digest-MD5          x86_64   2.55-440.fc32                fedora     36 k
 perl-Encode              x86_64   4:3.05-444.fc32              fedora    1.8 M
 perl-Errno               x86_64   1.30-452.fc32                fedora     24 k
 perl-Error               noarch   1:0.17029-1.fc32             fedora     42 k
 perl-Exporter            noarch   5.74-2.fc32                  fedora     32 k
 perl-File-Path           noarch   2.16-440.fc32                fedora     36 k
 perl-File-Temp           noarch   1:0.230.900-440.fc32         fedora     60 k
 perl-Getopt-Long         noarch   1:2.51-2.fc32                fedora     61 k
 perl-Git                 noarch   2.26.2-1.fc32                updates    45 k
 perl-HTTP-Tiny           noarch   0.076-440.fc32               fedora     55 k
 perl-IO                  x86_64   1.40-452.fc32                fedora     91 k
 perl-MIME-Base64         x86_64   3.15-440.fc32                fedora     30 k
 perl-Net-SSLeay          x86_64   1.88-5.fc32                  fedora    351 k
 perl-PathTools           x86_64   3.78-441.fc32                fedora     86 k
 perl-Pod-Escapes         noarch   1:1.07-440.fc32              fedora     20 k
 perl-Pod-Perldoc         noarch   3.28.01-443.fc32             fedora     85 k
 perl-Pod-Simple          noarch   1:3.40-2.fc32                fedora    215 k
 perl-Pod-Usage           noarch   4:1.70-1.fc32                fedora     33 k
 perl-Scalar-List-Utils   x86_64   3:1.54-440.fc32              fedora     69 k
 perl-Socket              x86_64   4:2.029-5.fc32               fedora     55 k
 perl-Storable            x86_64   1:3.15-443.fc32              fedora     97 k
 perl-Term-ANSIColor      noarch   5.01-2.fc32                  fedora     49 k
 perl-Term-Cap            noarch   1.17-440.fc32                fedora     22 k
 perl-TermReadKey         x86_64   2.38-6.fc32                  fedora     36 k
 perl-Text-ParseWords     noarch   3.30-440.fc32                fedora     16 k
 perl-Text-Tabs+Wrap      noarch   2013.0523-440.fc32           fedora     23 k
 perl-Time-Local          noarch   2:1.300-2.fc32               fedora     34 k
 perl-URI                 noarch   1.76-6.fc32                  fedora    109 k
 perl-Unicode-Normalize   x86_64   1.26-440.fc32                fedora     97 k
 perl-constant            noarch   1.33-441.fc32                fedora     23 k
 perl-interpreter         x86_64   4:5.30.2-452.fc32            fedora    6.0 M
 perl-libnet              noarch   3.11-441.fc32                fedora    117 k
 perl-libs                x86_64   4:5.30.2-452.fc32            fedora    1.7 M
 perl-macros              noarch   4:5.30.2-452.fc32            fedora     20 k
 perl-parent              noarch   1:0.238-1.fc32               fedora     14 k
 perl-podlators           noarch   1:4.14-2.fc32                fedora    113 k
 perl-threads             x86_64   1:2.22-442.fc32              fedora     59 k
 perl-threads-shared      x86_64   1.60-441.fc32                fedora     44 k
Installing weak dependencies:
 perl-IO-Socket-IP        noarch   0.39-441.fc32                fedora     42 k
 perl-IO-Socket-SSL       noarch   2.068-1.fc32                 fedora    217 k
 perl-Mozilla-CA          noarch   20180117-7.fc32              fedora     12 k

Transaction Summary
================================================================================
Install  55 Packages

Total download size: 22 M
Installed size: 93 M
Is this ok [y/N]: y
Downloading Packages:
(1/55): git-2.26.2-1.fc32.x86_64.rpm            358 kB/s | 126 kB     00:00
(2/55): libfido2-1.3.1-2.fc32.x86_64.rpm        707 kB/s |  65 kB     00:00
(3/55): openssh-8.2p1-3.fc32.x86_64.rpm         258 kB/s | 479 kB     00:01
(4/55): openssh-clients-8.2p1-3.fc32.x86_64.rpm 556 kB/s | 654 kB     00:01
(5/55): perl-Git-2.26.2-1.fc32.noarch.rpm       123 kB/s |  45 kB     00:00
(6/55): git-core-doc-2.26.2-1.fc32.noarch.rpm   562 kB/s | 2.2 MB     00:03
(7/55): emacs-filesystem-26.3-2.fc32.noarch.rpm  17 kB/s | 8.5 kB     00:00
(8/55): less-551-3.fc32.x86_64.rpm              198 kB/s | 156 kB     00:00
(9/55): libcbor-0.5.0-7.fc32.x86_64.rpm         184 kB/s |  46 kB     00:00
(10/55): groff-base-1.22.3-21.fc32.x86_64.rpm   488 kB/s | 1.0 MB     00:02
(11/55): git-core-2.26.2-1.fc32.x86_64.rpm      778 kB/s | 4.9 MB     00:06
(12/55): perl-Data-Dumper-2.174-443.fc32.x86_64 304 kB/s |  56 kB     00:00
(13/55): perl-Digest-1.17-440.fc32.noarch.rpm   191 kB/s |  24 kB     00:00
(14/55): perl-Digest-MD5-2.55-440.fc32.x86_64.r 229 kB/s |  36 kB     00:00
(15/55): perl-Carp-1.50-440.fc32.noarch.rpm      15 kB/s |  29 kB     00:01
(16/55): perl-Encode-3.05-444.fc32.x86_64.rpm   1.3 MB/s | 1.8 MB     00:01
(17/55): libedit-3.1-32.20191231cvs.fc32.x86_64  33 kB/s | 106 kB     00:03
(18/55): perl-Errno-1.30-452.fc32.x86_64.rpm     44 kB/s |  24 kB     00:00
(19/55): perl-Error-0.17029-1.fc32.noarch.rpm   103 kB/s |  42 kB     00:00
(20/55): perl-Exporter-5.74-2.fc32.noarch.rpm   136 kB/s |  32 kB     00:00
(21/55): perl-File-Path-2.16-440.fc32.noarch.rp 170 kB/s |  36 kB     00:00
(22/55): perl-File-Temp-0.230.900-440.fc32.noar 288 kB/s |  60 kB     00:00
(23/55): perl-HTTP-Tiny-0.076-440.fc32.noarch.r 269 kB/s |  55 kB     00:00
(24/55): perl-Getopt-Long-2.51-2.fc32.noarch.rp 279 kB/s |  61 kB     00:00
(25/55): perl-IO-1.40-452.fc32.x86_64.rpm       306 kB/s |  91 kB     00:00
(26/55): perl-IO-Socket-IP-0.39-441.fc32.noarch 189 kB/s |  42 kB     00:00
(27/55): perl-MIME-Base64-3.15-440.fc32.x86_64. 200 kB/s |  30 kB     00:00
(28/55): perl-Mozilla-CA-20180117-7.fc32.noarch 115 kB/s |  12 kB     00:00
(29/55): perl-IO-Socket-SSL-2.068-1.fc32.noarch 481 kB/s | 217 kB     00:00
(30/55): perl-PathTools-3.78-441.fc32.x86_64.rp 311 kB/s |  86 kB     00:00
(31/55): perl-Pod-Escapes-1.07-440.fc32.noarch. 117 kB/s |  20 kB     00:00
(32/55): perl-Net-SSLeay-1.88-5.fc32.x86_64.rpm 643 kB/s | 351 kB     00:00
(33/55): perl-Pod-Perldoc-3.28.01-443.fc32.noar 286 kB/s |  85 kB     00:00
(34/55): perl-Pod-Usage-1.70-1.fc32.noarch.rpm  201 kB/s |  33 kB     00:00
(35/55): perl-Pod-Simple-3.40-2.fc32.noarch.rpm 499 kB/s | 215 kB     00:00
(36/55): perl-Scalar-List-Utils-1.54-440.fc32.x 266 kB/s |  69 kB     00:00
(37/55): perl-Socket-2.029-5.fc32.x86_64.rpm    221 kB/s |  55 kB     00:00
(38/55): perl-Storable-3.15-443.fc32.x86_64.rpm 362 kB/s |  97 kB     00:00
(39/55): perl-Term-ANSIColor-5.01-2.fc32.noarch 248 kB/s |  49 kB     00:00
(40/55): perl-Term-Cap-1.17-440.fc32.noarch.rpm 134 kB/s |  22 kB     00:00
(41/55): perl-Text-ParseWords-3.30-440.fc32.noa 115 kB/s |  16 kB     00:00
(42/55): perl-TermReadKey-2.38-6.fc32.x86_64.rp 212 kB/s |  36 kB     00:00
(43/55): perl-Text-Tabs+Wrap-2013.0523-440.fc32 109 kB/s |  23 kB     00:00
(44/55): perl-Time-Local-1.300-2.fc32.noarch.rp 159 kB/s |  34 kB     00:00
(45/55): perl-URI-1.76-6.fc32.noarch.rpm        312 kB/s | 109 kB     00:00
(46/55): perl-constant-1.33-441.fc32.noarch.rpm 126 kB/s |  23 kB     00:00
(47/55): perl-Unicode-Normalize-1.26-440.fc32.x 263 kB/s |  97 kB     00:00
(48/55): perl-libnet-3.11-441.fc32.noarch.rpm   370 kB/s | 117 kB     00:00
(49/55): perl-macros-5.30.2-452.fc32.noarch.rpm 119 kB/s |  20 kB     00:00
(50/55): perl-parent-0.238-1.fc32.noarch.rpm    129 kB/s |  14 kB     00:00
(51/55): perl-podlators-4.14-2.fc32.noarch.rpm  261 kB/s | 113 kB     00:00
(52/55): perl-threads-2.22-442.fc32.x86_64.rpm  149 kB/s |  59 kB     00:00
(53/55): perl-threads-shared-1.60-441.fc32.x86_ 124 kB/s |  44 kB     00:00
(54/55): perl-libs-5.30.2-452.fc32.x86_64.rpm   858 kB/s | 1.7 MB     00:02
(55/55): perl-interpreter-5.30.2-452.fc32.x86_6 1.1 MB/s | 6.0 MB     00:05
--------------------------------------------------------------------------------
Total                                           1.2 MB/s |  22 MB     00:17
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1
  Installing       : perl-Exporter-5.74-2.fc32.noarch                      1/55
  Installing       : perl-libs-4:5.30.2-452.fc32.x86_64                    2/55
  Installing       : perl-Carp-1.50-440.fc32.noarch                        3/55
  Installing       : perl-Scalar-List-Utils-3:1.54-440.fc32.x86_64         4/55
  Installing       : perl-parent-1:0.238-1.fc32.noarch                     5/55
  Installing       : perl-Text-ParseWords-3.30-440.fc32.noarch             6/55
  Installing       : perl-Unicode-Normalize-1.26-440.fc32.x86_64           7/55
  Installing       : perl-Errno-1.30-452.fc32.x86_64                       8/55
  Installing       : perl-Socket-4:2.029-5.fc32.x86_64                     9/55
  Installing       : perl-Text-Tabs+Wrap-2013.0523-440.fc32.noarch        10/55
  Installing       : perl-File-Path-2.16-440.fc32.noarch                  11/55
  Installing       : perl-IO-1.40-452.fc32.x86_64                         12/55
  Installing       : perl-PathTools-3.78-441.fc32.x86_64                  13/55
  Installing       : perl-constant-1.33-441.fc32.noarch                   14/55
  Installing       : perl-macros-4:5.30.2-452.fc32.noarch                 15/55
  Installing       : perl-threads-1:2.22-442.fc32.x86_64                  16/55
  Installing       : perl-threads-shared-1.60-441.fc32.x86_64             17/55
  Installing       : perl-interpreter-4:5.30.2-452.fc32.x86_64            18/55
  Installing       : perl-MIME-Base64-3.15-440.fc32.x86_64                19/55
  Installing       : perl-IO-Socket-IP-0.39-441.fc32.noarch               20/55
  Installing       : perl-Time-Local-2:1.300-2.fc32.noarch                21/55
  Installing       : perl-File-Temp-1:0.230.900-440.fc32.noarch           22/55
  Installing       : perl-Digest-1.17-440.fc32.noarch                     23/55
  Installing       : perl-Digest-MD5-2.55-440.fc32.x86_64                 24/55
  Installing       : perl-Net-SSLeay-1.88-5.fc32.x86_64                   25/55
  Installing       : perl-Data-Dumper-2.174-443.fc32.x86_64               26/55
  Installing       : perl-Error-1:0.17029-1.fc32.noarch                   27/55
  Installing       : perl-Pod-Escapes-1:1.07-440.fc32.noarch              28/55
  Installing       : perl-Storable-1:3.15-443.fc32.x86_64                 29/55
  Installing       : perl-Term-Cap-1.17-440.fc32.noarch                   30/55
  Installing       : perl-TermReadKey-2.38-6.fc32.x86_64                  31/55
  Installing       : perl-Mozilla-CA-20180117-7.fc32.noarch               32/55
  Installing       : perl-Term-ANSIColor-5.01-2.fc32.noarch               33/55
  Installing       : libedit-3.1-32.20191231cvs.fc32.x86_64               34/55
  Installing       : libcbor-0.5.0-7.fc32.x86_64                          35/55
  Installing       : libfido2-1.3.1-2.fc32.x86_64                         36/55
  Installing       : less-551-3.fc32.x86_64                               37/55
  Installing       : groff-base-1.22.3-21.fc32.x86_64                     38/55
  Installing       : perl-HTTP-Tiny-0.076-440.fc32.noarch                 39/55
  Installing       : perl-libnet-3.11-441.fc32.noarch                     40/55
  Installing       : perl-IO-Socket-SSL-2.068-1.fc32.noarch               41/55
  Installing       : perl-URI-1.76-6.fc32.noarch                          42/55
  Installing       : perl-Encode-4:3.05-444.fc32.x86_64                   43/55
  Installing       : perl-Pod-Simple-1:3.40-2.fc32.noarch                 44/55
  Installing       : perl-Getopt-Long-1:2.51-2.fc32.noarch                45/55
  Installing       : perl-podlators-1:4.14-2.fc32.noarch                  46/55
  Installing       : perl-Pod-Perldoc-3.28.01-443.fc32.noarch             47/55
  Installing       : perl-Pod-Usage-4:1.70-1.fc32.noarch                  48/55
  Installing       : emacs-filesystem-1:26.3-2.fc32.noarch                49/55
  Running scriptlet: openssh-8.2p1-3.fc32.x86_64                          50/55
  Installing       : openssh-8.2p1-3.fc32.x86_64                          50/55
  Installing       : openssh-clients-8.2p1-3.fc32.x86_64                  51/55
  Installing       : git-core-2.26.2-1.fc32.x86_64                        52/55
  Installing       : git-core-doc-2.26.2-1.fc32.noarch                    53/55
  Installing       : perl-Git-2.26.2-1.fc32.noarch                        54/55
  Installing       : git-2.26.2-1.fc32.x86_64                             55/55
  Running scriptlet: git-2.26.2-1.fc32.x86_64                             55/55
  Verifying        : git-2.26.2-1.fc32.x86_64                              1/55
  Verifying        : git-core-2.26.2-1.fc32.x86_64                         2/55
  Verifying        : git-core-doc-2.26.2-1.fc32.noarch                     3/55
  Verifying        : libfido2-1.3.1-2.fc32.x86_64                          4/55
  Verifying        : openssh-8.2p1-3.fc32.x86_64                           5/55
  Verifying        : openssh-clients-8.2p1-3.fc32.x86_64                   6/55
  Verifying        : perl-Git-2.26.2-1.fc32.noarch                         7/55
  Verifying        : emacs-filesystem-1:26.3-2.fc32.noarch                 8/55
  Verifying        : groff-base-1.22.3-21.fc32.x86_64                      9/55
  Verifying        : less-551-3.fc32.x86_64                               10/55
  Verifying        : libcbor-0.5.0-7.fc32.x86_64                          11/55
  Verifying        : libedit-3.1-32.20191231cvs.fc32.x86_64               12/55
  Verifying        : perl-Carp-1.50-440.fc32.noarch                       13/55
  Verifying        : perl-Data-Dumper-2.174-443.fc32.x86_64               14/55
  Verifying        : perl-Digest-1.17-440.fc32.noarch                     15/55
  Verifying        : perl-Digest-MD5-2.55-440.fc32.x86_64                 16/55
  Verifying        : perl-Encode-4:3.05-444.fc32.x86_64                   17/55
  Verifying        : perl-Errno-1.30-452.fc32.x86_64                      18/55
  Verifying        : perl-Error-1:0.17029-1.fc32.noarch                   19/55
  Verifying        : perl-Exporter-5.74-2.fc32.noarch                     20/55
  Verifying        : perl-File-Path-2.16-440.fc32.noarch                  21/55
  Verifying        : perl-File-Temp-1:0.230.900-440.fc32.noarch           22/55
  Verifying        : perl-Getopt-Long-1:2.51-2.fc32.noarch                23/55
  Verifying        : perl-HTTP-Tiny-0.076-440.fc32.noarch                 24/55
  Verifying        : perl-IO-1.40-452.fc32.x86_64                         25/55
  Verifying        : perl-IO-Socket-IP-0.39-441.fc32.noarch               26/55
  Verifying        : perl-IO-Socket-SSL-2.068-1.fc32.noarch               27/55
  Verifying        : perl-MIME-Base64-3.15-440.fc32.x86_64                28/55
  Verifying        : perl-Mozilla-CA-20180117-7.fc32.noarch               29/55
  Verifying        : perl-Net-SSLeay-1.88-5.fc32.x86_64                   30/55
  Verifying        : perl-PathTools-3.78-441.fc32.x86_64                  31/55
  Verifying        : perl-Pod-Escapes-1:1.07-440.fc32.noarch              32/55
  Verifying        : perl-Pod-Perldoc-3.28.01-443.fc32.noarch             33/55
  Verifying        : perl-Pod-Simple-1:3.40-2.fc32.noarch                 34/55
  Verifying        : perl-Pod-Usage-4:1.70-1.fc32.noarch                  35/55
  Verifying        : perl-Scalar-List-Utils-3:1.54-440.fc32.x86_64        36/55
  Verifying        : perl-Socket-4:2.029-5.fc32.x86_64                    37/55
  Verifying        : perl-Storable-1:3.15-443.fc32.x86_64                 38/55
  Verifying        : perl-Term-ANSIColor-5.01-2.fc32.noarch               39/55
  Verifying        : perl-Term-Cap-1.17-440.fc32.noarch                   40/55
  Verifying        : perl-TermReadKey-2.38-6.fc32.x86_64                  41/55
  Verifying        : perl-Text-ParseWords-3.30-440.fc32.noarch            42/55
  Verifying        : perl-Text-Tabs+Wrap-2013.0523-440.fc32.noarch        43/55
  Verifying        : perl-Time-Local-2:1.300-2.fc32.noarch                44/55
  Verifying        : perl-URI-1.76-6.fc32.noarch                          45/55
  Verifying        : perl-Unicode-Normalize-1.26-440.fc32.x86_64          46/55
  Verifying        : perl-constant-1.33-441.fc32.noarch                   47/55
  Verifying        : perl-interpreter-4:5.30.2-452.fc32.x86_64            48/55
  Verifying        : perl-libnet-3.11-441.fc32.noarch                     49/55
  Verifying        : perl-libs-4:5.30.2-452.fc32.x86_64                   50/55
  Verifying        : perl-macros-4:5.30.2-452.fc32.noarch                 51/55
  Verifying        : perl-parent-1:0.238-1.fc32.noarch                    52/55
  Verifying        : perl-podlators-1:4.14-2.fc32.noarch                  53/55
  Verifying        : perl-threads-1:2.22-442.fc32.x86_64                  54/55
  Verifying        : perl-threads-shared-1.60-441.fc32.x86_64             55/55

Installed:
  emacs-filesystem-1:26.3-2.fc32.noarch
  git-2.26.2-1.fc32.x86_64
  git-core-2.26.2-1.fc32.x86_64
  git-core-doc-2.26.2-1.fc32.noarch
  groff-base-1.22.3-21.fc32.x86_64
  less-551-3.fc32.x86_64
  libcbor-0.5.0-7.fc32.x86_64
  libedit-3.1-32.20191231cvs.fc32.x86_64
  libfido2-1.3.1-2.fc32.x86_64
  openssh-8.2p1-3.fc32.x86_64
  openssh-clients-8.2p1-3.fc32.x86_64
  perl-Carp-1.50-440.fc32.noarch
  perl-Data-Dumper-2.174-443.fc32.x86_64
  perl-Digest-1.17-440.fc32.noarch
  perl-Digest-MD5-2.55-440.fc32.x86_64
  perl-Encode-4:3.05-444.fc32.x86_64
  perl-Errno-1.30-452.fc32.x86_64
  perl-Error-1:0.17029-1.fc32.noarch
  perl-Exporter-5.74-2.fc32.noarch
  perl-File-Path-2.16-440.fc32.noarch
  perl-File-Temp-1:0.230.900-440.fc32.noarch
  perl-Getopt-Long-1:2.51-2.fc32.noarch
  perl-Git-2.26.2-1.fc32.noarch
  perl-HTTP-Tiny-0.076-440.fc32.noarch
  perl-IO-1.40-452.fc32.x86_64
  perl-IO-Socket-IP-0.39-441.fc32.noarch
  perl-IO-Socket-SSL-2.068-1.fc32.noarch
  perl-MIME-Base64-3.15-440.fc32.x86_64
  perl-Mozilla-CA-20180117-7.fc32.noarch
  perl-Net-SSLeay-1.88-5.fc32.x86_64
  perl-PathTools-3.78-441.fc32.x86_64
  perl-Pod-Escapes-1:1.07-440.fc32.noarch
  perl-Pod-Perldoc-3.28.01-443.fc32.noarch
  perl-Pod-Simple-1:3.40-2.fc32.noarch
  perl-Pod-Usage-4:1.70-1.fc32.noarch
  perl-Scalar-List-Utils-3:1.54-440.fc32.x86_64
  perl-Socket-4:2.029-5.fc32.x86_64
  perl-Storable-1:3.15-443.fc32.x86_64
  perl-Term-ANSIColor-5.01-2.fc32.noarch
  perl-Term-Cap-1.17-440.fc32.noarch
  perl-TermReadKey-2.38-6.fc32.x86_64
  perl-Text-ParseWords-3.30-440.fc32.noarch
  perl-Text-Tabs+Wrap-2013.0523-440.fc32.noarch
  perl-Time-Local-2:1.300-2.fc32.noarch
  perl-URI-1.76-6.fc32.noarch
  perl-Unicode-Normalize-1.26-440.fc32.x86_64
  perl-constant-1.33-441.fc32.noarch
  perl-interpreter-4:5.30.2-452.fc32.x86_64
  perl-libnet-3.11-441.fc32.noarch
  perl-libs-4:5.30.2-452.fc32.x86_64
  perl-macros-4:5.30.2-452.fc32.noarch
  perl-parent-1:0.238-1.fc32.noarch
  perl-podlators-1:4.14-2.fc32.noarch
  perl-threads-1:2.22-442.fc32.x86_64
  perl-threads-shared-1.60-441.fc32.x86_64

Complete!

make のインストールを行う。

# dnf install make
Last metadata expiration check: 0:09:39 ago on Sun May  3 02:02:37 2020.
Dependencies resolved.
================================================================================
 Package             Architecture  Version                  Repository     Size
================================================================================
Installing:
 make                x86_64        1:4.2.1-16.fc32          fedora        494 k
Installing dependencies:
 gc                  x86_64        8.0.4-3.fc32             fedora        113 k
 guile22             x86_64        2.2.6-4.fc32             fedora        6.6 M
 libtool-ltdl        x86_64        2.4.6-33.fc32            fedora         37 k

Transaction Summary
================================================================================
Install  4 Packages

Total download size: 7.2 M
Installed size: 46 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): libtool-ltdl-2.4.6-33.fc32.x86_64.rpm    127 kB/s |  37 kB     00:00
(2/4): gc-8.0.4-3.fc32.x86_64.rpm               241 kB/s | 113 kB     00:00
(3/4): make-4.2.1-16.fc32.x86_64.rpm            1.0 MB/s | 494 kB     00:00
(4/4): guile22-2.2.6-4.fc32.x86_64.rpm          1.5 MB/s | 6.6 MB     00:04
--------------------------------------------------------------------------------
Total                                           1.2 MB/s | 7.2 MB     00:05
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1
  Installing       : libtool-ltdl-2.4.6-33.fc32.x86_64                      1/4
  Installing       : gc-8.0.4-3.fc32.x86_64                                 2/4
  Installing       : guile22-2.2.6-4.fc32.x86_64                            3/4
  Running scriptlet: guile22-2.2.6-4.fc32.x86_64                            3/4
  Installing       : make-1:4.2.1-16.fc32.x86_64                            4/4
  Running scriptlet: make-1:4.2.1-16.fc32.x86_64                            4/4
  Verifying        : gc-8.0.4-3.fc32.x86_64                                 1/4
  Verifying        : guile22-2.2.6-4.fc32.x86_64                            2/4
  Verifying        : libtool-ltdl-2.4.6-33.fc32.x86_64                      3/4
  Verifying        : make-1:4.2.1-16.fc32.x86_64                            4/4

Installed:
  gc-8.0.4-3.fc32.x86_64                    guile22-2.2.6-4.fc32.x86_64
  libtool-ltdl-2.4.6-33.fc32.x86_64         make-1:4.2.1-16.fc32.x86_64

Complete!

dnf-plugins-core のインストールを行う。

# dnf install dnf-plugins-core
Last metadata expiration check: 0:25:36 ago on Sun May  3 02:02:37 2020.
Dependencies resolved.
================================================================================
 Package                      Arch       Version              Repository   Size
================================================================================
Installing:
 dnf-plugins-core             noarch     4.0.15-1.fc32        updates      33 k
Upgrading:
 libdnf                       x86_64     0.47.0-1.fc32        updates     642 k
 librepo                      x86_64     1.11.3-1.fc32        updates      97 k
 python3-hawkey               x86_64     0.47.0-1.fc32        updates     114 k
 python3-libdnf               x86_64     0.47.0-1.fc32        updates     780 k
Installing dependencies:
 python3-dateutil             noarch     1:2.8.0-8.fc32       fedora      291 k
 python3-distro               noarch     1.4.0-5.fc32         fedora       35 k
 python3-dnf-plugins-core     noarch     4.0.15-1.fc32        updates     185 k
 python3-setuptools           noarch     41.6.0-2.fc32        fedora      588 k
 python3-six                  noarch     1.14.0-2.fc32        fedora       36 k

Transaction Summary
================================================================================
Install  6 Packages
Upgrade  4 Packages

Total download size: 2.7 M
Is this ok [y/N]: y
Downloading Packages:
(1/10): dnf-plugins-core-4.0.15-1.fc32.noarch.r 113 kB/s |  33 kB     00:00
(2/10): python3-distro-1.4.0-5.fc32.noarch.rpm  200 kB/s |  35 kB     00:00
(3/10): python3-dnf-plugins-core-4.0.15-1.fc32. 368 kB/s | 185 kB     00:00
(4/10): python3-dateutil-2.8.0-8.fc32.noarch.rp 485 kB/s | 291 kB     00:00
(5/10): python3-six-1.14.0-2.fc32.noarch.rpm    200 kB/s |  36 kB     00:00
(6/10): librepo-1.11.3-1.fc32.x86_64.rpm        719 kB/s |  97 kB     00:00
(7/10): libdnf-0.47.0-1.fc32.x86_64.rpm         984 kB/s | 642 kB     00:00
(8/10): python3-hawkey-0.47.0-1.fc32.x86_64.rpm 235 kB/s | 114 kB     00:00
(9/10): python3-setuptools-41.6.0-2.fc32.noarch 633 kB/s | 588 kB     00:00
(10/10): python3-libdnf-0.47.0-1.fc32.x86_64.rp 454 kB/s | 780 kB     00:01
--------------------------------------------------------------------------------
Total                                           551 kB/s | 2.7 MB     00:05
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1
  Upgrading        : librepo-1.11.3-1.fc32.x86_64                          1/14
  Upgrading        : libdnf-0.47.0-1.fc32.x86_64                           2/14
  Upgrading        : python3-libdnf-0.47.0-1.fc32.x86_64                   3/14
  Upgrading        : python3-hawkey-0.47.0-1.fc32.x86_64                   4/14
  Installing       : python3-six-1.14.0-2.fc32.noarch                      5/14
  Installing       : python3-dateutil-1:2.8.0-8.fc32.noarch                6/14
  Installing       : python3-setuptools-41.6.0-2.fc32.noarch               7/14
  Installing       : python3-distro-1.4.0-5.fc32.noarch                    8/14
  Installing       : python3-dnf-plugins-core-4.0.15-1.fc32.noarch         9/14
  Installing       : dnf-plugins-core-4.0.15-1.fc32.noarch                10/14
  Cleanup          : python3-hawkey-0.45.0-3.fc32.x86_64                  11/14
  Cleanup          : python3-libdnf-0.45.0-3.fc32.x86_64                  12/14
  Cleanup          : libdnf-0.45.0-3.fc32.x86_64                          13/14
  Cleanup          : librepo-1.11.1-4.fc32.x86_64                         14/14
  Running scriptlet: librepo-1.11.1-4.fc32.x86_64                         14/14
  Verifying        : dnf-plugins-core-4.0.15-1.fc32.noarch                 1/14
  Verifying        : python3-dnf-plugins-core-4.0.15-1.fc32.noarch         2/14
  Verifying        : python3-dateutil-1:2.8.0-8.fc32.noarch                3/14
  Verifying        : python3-distro-1.4.0-5.fc32.noarch                    4/14
  Verifying        : python3-setuptools-41.6.0-2.fc32.noarch               5/14
  Verifying        : python3-six-1.14.0-2.fc32.noarch                      6/14
  Verifying        : libdnf-0.47.0-1.fc32.x86_64                           7/14
  Verifying        : libdnf-0.45.0-3.fc32.x86_64                           8/14
  Verifying        : librepo-1.11.3-1.fc32.x86_64                          9/14
  Verifying        : librepo-1.11.1-4.fc32.x86_64                         10/14
  Verifying        : python3-hawkey-0.47.0-1.fc32.x86_64                  11/14
  Verifying        : python3-hawkey-0.45.0-3.fc32.x86_64                  12/14
  Verifying        : python3-libdnf-0.47.0-1.fc32.x86_64                  13/14
  Verifying        : python3-libdnf-0.45.0-3.fc32.x86_64                  14/14

Upgraded:
  libdnf-0.47.0-1.fc32.x86_64            librepo-1.11.3-1.fc32.x86_64
  python3-hawkey-0.47.0-1.fc32.x86_64    python3-libdnf-0.47.0-1.fc32.x86_64

Installed:
  dnf-plugins-core-4.0.15-1.fc32.noarch
  python3-dateutil-1:2.8.0-8.fc32.noarch
  python3-distro-1.4.0-5.fc32.noarch
  python3-dnf-plugins-core-4.0.15-1.fc32.noarch
  python3-setuptools-41.6.0-2.fc32.noarch
  python3-six-1.14.0-2.fc32.noarch

Complete!

genie をソースコードからインストールする。

# git clone https://github.com/arkane-systems/genie.git
Cloning into 'genie'...
remote: Enumerating objects: 96, done.
remote: Counting objects: 100% (96/96), done.
remote: Compressing objects: 100% (60/60), done.
remote: Total 537 (delta 37), reused 72 (delta 26), pack-reused 441
Receiving objects: 100% (537/537), 99.77 KiB | 322.00 KiB/s, done.
Resolving deltas: 100% (238/238), done.
# cd genie
# make install

付録 LxRunOffline コマンド オプション[翻訳]

LxRunOffline

$ LxRunOffline

サポートされているオプション

Supported actions are:
    l, list            List all installed distributions.
    gd, get-default    Get the default distribution, which is used by bash.exe.
    sd, set-default    Set the default distribution, which is used by bash.exe.
    i, install         Install a new distribution.
    ui, uninstall      Uninstall a distribution.
    rg, register       Register an existing installation directory.
    ur, unregister     Unregister a distribution but not delete the installation directory.
    m, move            Move a distribution to a new directory.
    d, duplicate       Duplicate an existing distribution in a new directory.
    e, export          Export a distribution's filesystem to a .tar.gz file, which can be imported by the "install" command.
    r, run             Run a command in a distribution.
    di, get-dir        Get the installation directory of a distribution.
    gv, get-version    Get the filesystem version of a distribution.
    ge, get-env        Get the default environment variables of a distribution.
    se, set-env        Set the default environment variables of a distribution.
    ae, add-env        Add to the default environment variables of a distribution.
    re, remove-env     Remove from the default environment variables of a distribution.
    gu, get-uid        Get the UID of the default user of a distribution.
    su, set-uid        Set the UID of the default user of a distribution.
    gk, get-kernelcmd  Get the default kernel command line of a distribution.
    sk, set-kernelcmd  Set the default kernel command line of a distribution.
    gf, get-flags      Get some flags of a distribution. See https://docs.microsoft.com/en-us/previous-versions/windows/desktop/api/wslapi/ne-wslapi-wsl_distribution_flags for details.
    sf, set-flags      Set some flags of a distribution. See https://docs.microsoft.com/en-us/previous-versions/windows/desktop/api/wslapi/ne-wslapi-wsl_distribution_flags for details.
    s, shortcut        Create a shortcut to launch a distribution.
    ec, export-config  Export configuration of a distribution to an XML file.
    ic, import-config  Import configuration of a distribution from an XML file.
    sm, summary        Get general information of a distribution.
    version            Get version information about this LxRunOffline.exe.

サポートされているオプション(日本語訳)

サポートされているアクションは次のとおりです。
    l, list            インストールされているすべてのディストリビューションをリストします。
    gd, get-default    bash.exe によって使用されるデフォルトのディストリビューションを取得します。
    sd, set-default    bash.exe が使用するデフォルトのディストリビューションを設定します。
    i, install         新しいディストリビューションをインストールします。
    ui, uninstall      ディストリビューションをアンインストールします。
    rg, register       既存のインストールディレクトリを登録します。
    ur, unregister     ディストリビューションの登録を解除しますが、インストールディレクトリは削除しません。
    m, move            ディストリビューションを新しいディレクトリに移動します。
    d, duplicate       既存のディストリビューションを新しいディレクトリに複製します。
    e, export          ディストリビューションのファイルシステムを .tar.gz ファイルにエクスポートします。これは、「install」コマンドでインポートできます。
    r, run             ディストリビューションでコマンドを実行します。
    di, get-dir        ディストリビューションのインストールディレクトリを取得します。
    gv, get-version    ディストリビューションのファイルシステムのバージョンを取得します。
    ge, get-env        ディストリビューションのデフォルトの環境変数を取得します。
    se, set-env        ディストリビューションのデフォルトの環境変数を設定します。
    ae, add-env        ディストリビューションのデフォルトの環境変数に追加します。
    re, remove-env     ディストリビューションのデフォルトの環境変数から削除します。
    gu, get-uid        ディストリビューションのデフォルトユーザーの UID を取得します。
    su, set-uid        ディストリビューションのデフォルトユーザーの UID を設定します。
    gk, get-kernelcmd  ディストリビューションのデフォルトのカーネルコマンドラインを取得します。
    sk, set-kernelcmd  ディストリビューションのデフォルトのカーネルコマンドラインを設定します。
    gf, get-flags      ディストリビューションのいくつかのフラグを取得します。詳細については、https://docs.microsoft.com/en-us/previous-versions/windows/desktop/api/wslapi/ne-wslapi-wsl_distribution_flags を参照してください。
    sf, set-flags      ディストリビューションのいくつかのフラグを設定します。詳細については、https://docs.microsoft.com/en-us/previous-versions/windows/desktop/api/wslapi/ne-wslapi-wsl_distribution_flags を参照してください。
    s, shortcut        ディストリビューションを起動するためのショートカットを作成します。
    ec, export-config  ディストリビューションの構成を XML ファイルにエクスポートします。
    ic, import-config  XML ファイルからディストリビューションの構成をインポートします。
    sm, summary        配布の一般情報を取得します。
    version            この LxRunOffline.exe に関するバージョン情報を取得します。

LxRunOffline[i, install]

$ LxRunOffline i

サポートされているオプション

Options:
  -n arg                Name of the distribution
  -d arg                The directory to install the distribution into.
  -f arg                The tar file containing the root filesystem of the
                        distribution to be installed. If a file of the same
                        name with a .xml extension exists and "-c" isn't
                        specified, that file will be imported as a config file.
  -r arg                The directory in the tar file to extract. This argument
                        is optional.
  -c arg                The config file to use. This argument is optional.
  -v arg (=2)           The version of filesystem to use, latest available one
                        if not specified.
  -s                    Create a shortcut for this distribution on Desktop.

オプション(日本語訳)

オプション:
  -n arg                ディストリビューションの名前
  -d arg                ディストリビューションをインストールするディレクトリ。
  -f arg                ルートファイルシステムを含む tar ファイル
                        インストールするディストリビューション。同じのファイルなら
                        拡張子が .xml の名前が存在し、「-c」が存在しない
                        指定すると、そのファイルは設定ファイルとしてインポートされます。
  -r arg                抽出するtarファイル内のディレクトリ。この議論
                        オプションです。
  -c arg                使用する設定ファイル。この引数はオプションです。
  -v arg (=2)           使用するファイルシステムのバージョン、利用可能な最新のもの
                        指定されていない場合。
  -s                    デスクトップにこのディストリビューションのショートカットを作成します。

トラブルシューティング

dnf / rpm コマンドが rpmdb のオープンに失敗する

$ dnf list installed
error: db5 error(12) from dbenv->open: Cannot allocate memory
error: db5 error(22) from dbenv->close: Invalid argument
error: cannot open Packages index using db5 - Cannot allocate memory (12)
error: cannot open Packages database in /var/lib/rpm
Error: Error: rpmdb open failed
$ rpm -qa
error: db5 error(12) from dbenv->open: Cannot allocate memory
error: db5 error(22) from dbenv->close: Invalid argument
error: cannot open Packages index using db5 - Cannot allocate memory (12)
error: cannot open Packages database in /var/lib/rpm
error: db5 error(12) from dbenv->open: Cannot allocate memory
error: db5 error(22) from dbenv->close: Invalid argument
error: cannot open Packages index using db5 - Cannot allocate memory (12)
error: cannot open Packages database in /var/lib/rpm

1668379 – Under Microsoft WIndows Subsystem for Linux (WSL) - Error: rpmdb open failed [fedora]

参考文献

windows/wsl/lxrunoffline.txt · 最終更新: 2020/07/03 04:28 by ともやん